summaryrefslogtreecommitdiff
path: root/dev-python/webpy/webpy-0.37-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webpy/webpy-0.37-r1.ebuild')
-rw-r--r--dev-python/webpy/webpy-0.37-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/webpy/webpy-0.37-r1.ebuild b/dev-python/webpy/webpy-0.37-r1.ebuild
new file mode 100644
index 00000000000..99227579bdd
--- /dev/null
+++ b/dev-python/webpy/webpy-0.37-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for Python"
+HOMEPAGE="http://www.webpy.org http://pypi.python.org/pypi/web.py"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/web.py-${PV}"
+
+python_test() {
+ local return_status="0" test tests="db http net template utils"
+ for test in ${tests}; do
+ echo "Running doctests in ${test}.py..."
+ "${PYTHON}" web/${test}.py || return_status="$?"
+ done
+ return "${return_status}"
+}