summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-0.21.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.21.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.21.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.21.0.ebuild b/dev-python/websocket-client/websocket-client-0.21.0.ebuild
new file mode 100644
index 00000000000..889ab1c8bcb
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.21.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="WebSocket client for python. hybi13 is supported"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
+"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}