summaryrefslogtreecommitdiff
path: root/dev-python/webut/webut-0.1.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webut/webut-0.1.0.2-r1.ebuild')
-rw-r--r--dev-python/webut/webut-0.1.0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/webut/webut-0.1.0.2-r1.ebuild b/dev-python/webut/webut-0.1.0.2-r1.ebuild
new file mode 100644
index 00000000000..7bef4ed2520
--- /dev/null
+++ b/dev-python/webut/webut-0.1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+MY_P=${PN}_$(replace_version_separator 2 '-')
+
+DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
+HOMEPAGE="http://www.inoi.fi/open/trac/webut"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/nevow-0.9.18[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}