summaryrefslogtreecommitdiff
path: root/dev-python/webut/webut-0.1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/webut/webut-0.1.0.2.ebuild')
-rw-r--r--dev-python/webut/webut-0.1.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/webut/webut-0.1.0.2.ebuild b/dev-python/webut/webut-0.1.0.2.ebuild
new file mode 100644
index 00000000000..4031e1365a0
--- /dev/null
+++ b/dev-python/webut/webut-0.1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_P=${PN}_$(replace_version_separator 2 '-')
+
+DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
+HOMEPAGE="http://www.inoi.fi/open/trac/webut"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/nevow-0.9.18
+ >=dev-python/twisted-core-2
+ >=dev-python/zope-interface-3.0.1"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ rm -rf "${D}/examples"
+}