summaryrefslogtreecommitdiff
path: root/dev-python/yenc/yenc-0.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yenc/yenc-0.4.0-r1.ebuild')
-rw-r--r--dev-python/yenc/yenc-0.4.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/yenc/yenc-0.4.0-r1.ebuild b/dev-python/yenc/yenc-0.4.0-r1.ebuild
new file mode 100644
index 00000000000..f5a1d157824
--- /dev/null
+++ b/dev-python/yenc/yenc-0.4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding"
+HOMEPAGE="http://www.golug.it/yenc.html"
+SRC_URI="http://www.golug.it/pub/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Remove forced CFLAG on setup.py
+PATCHES=( "${FILESDIR}"/${PN}-remove-cflags.patch )
+DOCS=( README TODO CHANGES doc/${PN}-draft.1.3.txt )
+
+python_test() {
+ "${PYTHON}" test/test.py || die "Test failed."
+}
+
+src_test() {
+ # Tests use a constant temp file.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}