summaryrefslogtreecommitdiff
path: root/dev-python/zake/zake-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zake/zake-0.2.1.ebuild')
-rw-r--r--dev-python/zake/zake-0.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/zake/zake-0.2.1.ebuild b/dev-python/zake/zake-0.2.1.ebuild
new file mode 100644
index 00000000000..9a197203e6b
--- /dev/null
+++ b/dev-python/zake/zake-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python package that works to provide a nice set of testing utilities for the kazoo library."
+HOMEPAGE=" https://github.com/yahoo/Zake"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/kazoo[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m nose || die
+}