summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bsddb3/bsddb3-6.1.1.ebuild2
-rw-r--r--dev-python/hacking/hacking-0.10.2.ebuild4
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-4.2.2.ebuild32
-rw-r--r--dev-python/logbook/logbook-0.9.1.ebuild6
-rw-r--r--dev-python/nose/nose-1.3.4.ebuild4
-rw-r--r--dev-python/nose/nose-1.3.6.ebuild4
-rw-r--r--dev-python/nose/nose-1.3.7.ebuild22
-rw-r--r--dev-python/nose/nose-9999.ebuild4
-rw-r--r--dev-python/numpy/numpy-1.10.2-r2.ebuild (renamed from dev-python/numpy/numpy-1.10.2-r1.ebuild)27
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-3.1.0.ebuild94
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild8
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2015.2.4.ebuild47
-rw-r--r--dev-python/pyshark/pyshark-0.3.6.ebuild7
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.5.ebuild2
-rw-r--r--dev-python/trollius/trollius-2.0.ebuild6
18 files changed, 231 insertions, 41 deletions
diff --git a/dev-python/bsddb3/bsddb3-6.1.1.ebuild b/dev-python/bsddb3/bsddb3-6.1.1.ebuild
index 303422a4564..dd083cc6495 100644
--- a/dev-python/bsddb3/bsddb3-6.1.1.ebuild
+++ b/dev-python/bsddb3/bsddb3-6.1.1.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
RDEPEND="
diff --git a/dev-python/hacking/hacking-0.10.2.ebuild b/dev-python/hacking/hacking-0.10.2.ebuild
index 18be6bec54f..a9fc430a0c7 100644
--- a/dev-python/hacking/hacking-0.10.2.ebuild
+++ b/dev-python/hacking/hacking-0.10.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -51,7 +51,7 @@ python_prepare_all() {
-e 's:oslosphinx:oslo.sphinx:' \
-i doc/source/conf.py || die
# relax deps
- rm requirements.txt
+ rm *requirements.txt hacking.egg-info/requires.txt || die
distutils-r1_python_prepare_all
}
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index c842fd7663f..209e1c4f318 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,2 +1,3 @@
DIST ipykernel-4.2.0.tar.gz 80543 SHA256 723b3d4baac20f0c9cd91fc75c3e813636ecb6c6e303fb34d628c3df078985a7 SHA512 32d3d3e594031c16b3ae4736f72e168263d44be15e1a546b4f69614bef30d80ff44db00699be086897c1c384b71600f3cd7bd702b45136f51aab526c2c018f25 WHIRLPOOL e1f335dd68068e338998ac7198db43cee6d06ce19f6f6a40c7da5509beb16fed24b86eb89dcab468fc344d8d4fd090963f74f46aa119013591abf4d3463bccfa
DIST ipykernel-4.2.1.tar.gz 500015 SHA256 081a5d4db33db58697be2d682b92f79b2c239493445f13dd457c15bc3e52c874 SHA512 cb3b27c7e6dbc93ccd4f3a288f658c33b62da28123847729be22613f7c0112d8fd79f1113bb64dcd685a7aa096835e80a6fe788b1cfde7687dab48c5af921509 WHIRLPOOL a1868031cee21cdb07f3a74a4af905a964cf0f1fd57ff928ecabc20399955ddf435295caca19eff044c177e926d61dcc395154fe4de7a108a1bfe89104d86705
+DIST ipykernel-4.2.2.tar.gz 80780 SHA256 a876da43e01acec2c305abdd8e6aa55f052bab1196171ccf1cb9a6aa230298b0 SHA512 8b7853b5f2602377d696f2c82cc5b2dd4cf2c0b1fb907b3a76aaad034d3f97ace374db86e30b33c83ccaad5ea9ae42229349610789f844ca5b67d9b806df9b4c WHIRLPOOL c15a46abb3adbd9b2fd855de3d060151d7392a06a43aff301c4f854a9daeb0463526f57883f37c02f1efbe4812ff9baca1fccc713ad19e7bd086739f4377dda8
diff --git a/dev-python/ipykernel/ipykernel-4.2.2.ebuild b/dev-python/ipykernel/ipykernel-4.2.2.ebuild
new file mode 100644
index 00000000000..ac4257b1860
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-4.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose ipykernel || die
+}
diff --git a/dev-python/logbook/logbook-0.9.1.ebuild b/dev-python/logbook/logbook-0.9.1.ebuild
index 35b853d1293..68f464f9b53 100644
--- a/dev-python/logbook/logbook-0.9.1.ebuild
+++ b/dev-python/logbook/logbook-0.9.1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
inherit distutils-r1
@@ -17,7 +18,8 @@ KEYWORDS="amd64 x86"
IUSE="doc test"
DISTUTILS_IN_SOURCE_BUILD=1
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
diff --git a/dev-python/nose/nose-1.3.4.ebuild b/dev-python/nose/nose-1.3.4.ebuild
index 61cff467b38..6d77007c155 100644
--- a/dev-python/nose/nose-1.3.4.ebuild
+++ b/dev-python/nose/nose-1.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
HOMEPAGE="https://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
diff --git a/dev-python/nose/nose-1.3.6.ebuild b/dev-python/nose/nose-1.3.6.ebuild
index 3c80cdd3061..fe1725e007f 100644
--- a/dev-python/nose/nose-1.3.6.ebuild
+++ b/dev-python/nose/nose-1.3.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -9,7 +9,7 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
HOMEPAGE="
https://pypi.python.org/pypi/nose
http://readthedocs.org/docs/nose/
diff --git a/dev-python/nose/nose-1.3.7.ebuild b/dev-python/nose/nose-1.3.7.ebuild
index 7e9d8050224..a059793bf0b 100644
--- a/dev-python/nose/nose-1.3.7.ebuild
+++ b/dev-python/nose/nose-1.3.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -9,7 +9,7 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
HOMEPAGE="
https://pypi.python.org/pypi/nose
http://readthedocs.org/docs/nose/
@@ -21,6 +21,11 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc examples test"
+REQUIRED_USE="
+ doc? (
+ || ( $(python_gen_useflags 'python2*') )
+ )"
+
RDEPEND="
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -28,6 +33,10 @@ DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
# Tests need to be converted, and they don't respect BUILD_DIR.
use test && DISTUTILS_IN_SOURCE_BUILD=1
@@ -61,7 +70,10 @@ python_compile() {
}
python_compile_all() {
- use doc && emake -C doc html
+ if use doc; then
+ python_setup 'python2*'
+ emake -C doc html
+ fi
}
python_test() {
@@ -74,9 +86,7 @@ python_install() {
python_install_all() {
use examples && local EXAMPLES=( examples/. )
+ use doc && HTML_DOCS=( doc/.build/html/. )
distutils-r1_python_install_all
- if use doc; then
- dohtml -r -A txt doc/.build/html/.
- fi
}
diff --git a/dev-python/nose/nose-9999.ebuild b/dev-python/nose/nose-9999.ebuild
index 261ed7f9d52..fa4b126cf84 100644
--- a/dev-python/nose/nose-9999.ebuild
+++ b/dev-python/nose/nose-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,7 +14,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 eutils
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
HOMEPAGE="https://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://github.com/nose-devs/nose"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
diff --git a/dev-python/numpy/numpy-1.10.2-r1.ebuild b/dev-python/numpy/numpy-1.10.2-r2.ebuild
index 9dc68cdc08f..33f693b40a1 100644
--- a/dev-python/numpy/numpy-1.10.2-r1.ebuild
+++ b/dev-python/numpy/numpy-1.10.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -105,12 +105,12 @@ python_prepare_all() {
[[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
fi
- # don't version f2py, we will handle it.
- sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
+# # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
- # we don't have f2py-3.3
+# # we don't have f2py-3.3
sed \
- -e "/f2py_cmd/s:'f2py'.*:'f2py'\]:g" \
+ -e 's:test_f2py:_&:g' \
-i numpy/tests/test_scripts.py || die
distutils-r1_python_prepare_all
@@ -135,17 +135,16 @@ python_install() {
}
python_install_all() {
- distutils-r1_python_install_all
-
- dodoc COMPATIBILITY DEV_README.txt THANKS.txt
+ DOCS+=( COMPATIBILITY DEV_README.txt THANKS.txt )
if use doc; then
- dohtml -r "${WORKDIR}"/html/*
- dodoc "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf
+ HTML_DOCS=( "${WORKDIR}"/html/. )
+ DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf )
fi
- # absent in 1.9
- #docinto f2py
- #dodoc numpy/f2py/docs/*.txt
- #doman numpy/f2py/f2py.1
+ distutils-r1_python_install_all
+
+ docinto f2py
+ dodoc doc/f2py/*.txt
+ doman doc/f2py/f2py.1
}
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 6d875aee4c4..17f4e9d4211 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -2,3 +2,4 @@ DIST Pillow-2.8.1.zip 9275663 SHA256 4363b52527c263e77f5b18c3dfffd15ae454edf0c44
DIST Pillow-2.8.2.zip 9402887 SHA256 57a900c2f30e53ed054adad401ab69643d9ab21e3acb0a647749a168e4e24446 SHA512 2bc1e17cb65d5e953e30ea1606dbf79059d51f60ff5c2b000869fc2d9f93f8bbf5cf41b0147fc83974c48341cc68df6964d3d8203e0d6cc6a45ede95f3e0bc2f WHIRLPOOL 4b5ad1db34427a161ce1885a858df72e4aaffd61b5bf9010702803874f44391678d228f71777fca058f424c6ac6208e8c3d7421eeff88c42bb6df94d1d13d771
DIST Pillow-2.9.0.zip 9612840 SHA256 d1db8dfed77547076037d589b598e04f2cbc1a7835d3d3f137bf20c8994854d5 SHA512 d06371fbe67eca66229cdec7896423f55c9335be50698168c7bf4f4635352454b2f946eae90b404c68d6b939ec1d7353916d32bc9964d5b8986b8098381d5180 WHIRLPOOL c664fec07c6634cad37791375fb1cb38b0edd542d93e099703dbc520e0d54125a1f00f205bbcdb8493df4dfd05ae1c2088ba305f23e66f0cc3e309f446c44fa5
DIST Pillow-3.0.0.zip 9947593 SHA256 0024fce578547a3da92579a163bae09b1d9f0baf3cd8e4a893dc6c11e4e624bb SHA512 59dd809160743d2740dfe64743dc674bb4cb6395914048d0d555ccacc7fee1c8f3a114ec39142b5495a0162a74acaadf7ad66694f97c7f221ccffe19cd656928 WHIRLPOOL 0fe2c9af2557278cc855ec7ddb4cfd944fbd1fc3cb2a614e84bd1dfa0c8ba243e60bda863b0b254098bcc7510d62953dbccf1fce88996011327f1059df0b69fb
+DIST Pillow-3.1.0.zip 10077136 SHA256 d2cf322edab56fa5cf5400c96a2dbcf7062ef0ba7345ca4c2798be5595e16330 SHA512 4f9608ef7294a27dec78fbf8ea888ecaebea9199f4eb9167ff883b261f37ac4b01b3375e8c93567c9d6bbbacf80775fdd91abc8f0a7ef02528ba89ed858cce7d WHIRLPOOL 4a4eb8bd9a8356580033a39d31db5b86f54ee14f520c3b135ab1e6385730258481d558d28e9ad3b6257fe862508c8a385982b34791ba90da419e06f5657f700d
diff --git a/dev-python/pillow/pillow-3.1.0.ebuild b/dev-python/pillow/pillow-3.1.0.ebuild
new file mode 100644
index 00000000000..62d6a0d084c
--- /dev/null
+++ b/dev-python/pillow/pillow-3.1.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 eutils virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+
+REQUIRED_USE="test? ( jpeg tiff )"
+
+RDEPEND="
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-better-theme[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx_rtd_theme-0.2[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+# See _render and _clean in Tests/test_imagefont.py
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable all the stuff we don't want.
+ local f
+ for f in jpeg lcms tiff tk webp zlib; do
+ if ! use ${f}; then
+ sed -i -e "s:feature.${f} =:& None #:" setup.py || die
+ fi
+ done
+ if ! use truetype; then
+ sed -i -e 's:feature.freetype =:& None #:' setup.py || die
+ fi
+ if ! use jpeg2k; then
+ sed -i -e 's:feature.jpeg2000 =:& None #:' setup.py || die
+ fi
+
+ sed \
+ -e "/required/s:=.*:= set():g" \
+ -e "/if f in/s:'jpeg', 'libz'::g" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ virtx nosetests -vx Tests/test_*.py
+}
+
+python_install() {
+ python_doheader libImaging/{Imaging.h,ImPlatform.h}
+
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( Scripts/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
index 9b06f54c440..063ce707be1 100644
--- a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,9 +24,9 @@ DEPEND="${RDEPEND}
python_test() {
echoit() { echo "$@"; "$@"; }
local exit_status=0 test
- for test in test/*.sh; do
- PATH="${S}/tools:${PATH}" \
- echoit sh "${test}" || exit_status=1
+ cd tools || die
+ for test in ../test/*.sh; do
+ echoit sh "${test}" || exit_status=1
done
return ${exit_status}
}
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 3f25ec0d2a0..fca65c2e3cb 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1,3 @@
DIST pyopencl-2014.1.tar.gz 1642825 SHA256 7c8df4f22ef49516a1444760dc622a037c83079ff60ff81779e60cb9fc5410e7 SHA512 da3e4e8d95605381d87db482f61fe7030fe244611a3c35d84c88210bcfb3472dc197be721f92e46e6828cc5d0245981ae004331a7c19e7fd8011a0aab593072f WHIRLPOOL e9d3c742c6ef217cf1f223990f852ae5b5ef50b7eae3513955da00f41134d9805e2078c16cd31429e327ea64a7ea16c15c014a749a3a532c3a11e4babdb91202
DIST pyopencl-2015.1.tar.gz 1652046 SHA256 823b8c5ae438a70de87b3675c3896d04d785261cb0cbd45c01c7dd0fe9d9f6ff SHA512 0236237b1f21283aa2fa7edf86d4c7a275df508e2bdd833ad83d333f3a070b00b125310bfbf8e0fd7308b47d94c565642f87645cc91c8d7020f1e377cdd8bec5 WHIRLPOOL 2b581e4a02c8f5f77085c87c5e8b63ada0b86c58d04e62e665144be00447a9cdd69e8befecc3effe8b6253f3cace2920e8158417c940d08f89ff2985c479753b
+DIST pyopencl-2015.2.4.tar.gz 284648 SHA256 f67d0099add79c6baae2359872dec82d1472bd4df42523d1604afcd10ed87398 SHA512 19ae397adb357da2e04d8aade987471b7c83b902750aeb67bf5303e758b720d78ce05a130b1930478ccc47ff6c3cdf4484b85d4bf60dfb36aaf6e2f050a4af9e WHIRLPOOL b0fa45f68ccc05d45036ead1c9e6be0aff06c06f45d6c53f1dcbce2a1c70acf5e4ccbcbffea1966a3aa4a752f909c306296a2905bf7331cfd36d9b083d263f61
diff --git a/dev-python/pyopencl/pyopencl-2015.2.4.ebuild b/dev-python/pyopencl/pyopencl-2015.2.4.ebuild
new file mode 100644
index 00000000000..82979731fc9
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2015.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl https://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyshark/pyshark-0.3.6.ebuild b/dev-python/pyshark/pyshark-0.3.6.ebuild
index 752b5295a71..e9cb16034b2 100644
--- a/dev-python/pyshark/pyshark-0.3.6.ebuild
+++ b/dev-python/pyshark/pyshark-0.3.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1 eutils
@@ -19,7 +19,8 @@ IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# See pyshark.egg-info/requires.txt
-RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
dev-python/logbook[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/trollius[${PYTHON_USEDEP}]
diff --git a/dev-python/pyxattr/pyxattr-0.5.5.ebuild b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
index eaff3d74a34..20954898f98 100644
--- a/dev-python/pyxattr/pyxattr-0.5.5.ebuild
+++ b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
IUSE="doc test"
RDEPEND="sys-apps/attr"
diff --git a/dev-python/trollius/trollius-2.0.ebuild b/dev-python/trollius/trollius-2.0.ebuild
index b15094c7a12..2d842214cb1 100644
--- a/dev-python/trollius/trollius-2.0.ebuild
+++ b/dev-python/trollius/trollius-2.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
inherit distutils-r1
DESCRIPTION="A port of the Tulip project (asyncio module, PEP3156)"