summaryrefslogtreecommitdiff
path: root/dev-ros/image_rotate/files/gcc6.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_rotate/files/gcc6.patch')
-rw-r--r--dev-ros/image_rotate/files/gcc6.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ros/image_rotate/files/gcc6.patch b/dev-ros/image_rotate/files/gcc6.patch
deleted file mode 100644
index e0737b47cbc..00000000000
--- a/dev-ros/image_rotate/files/gcc6.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 6c2d65452bd5fe62723988a1a570789921900d59
-Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Fri Sep 30 15:39:47 2016 +0200
-
- address gcc6 build error
-
- With gcc6, compiling fails with `stdlib.h: No such file or directory`,
- as including '-isystem /usr/include' breaks with gcc6, cf.,
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
-
- This commit addresses this issue for this package in the same way
- it was addressed in various other ROS packages. A list of related
- commits and pull requests is at:
-
- https://github.com/ros/rosdistro/issues/12783
-
- Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-
-diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
-index 04ba03b..75d8e77 100644
---- a/image_rotate/CMakeLists.txt
-+++ b/image_rotate/CMakeLists.txt
-@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
- find_package(Eigen REQUIRED)
-
- # add the executable
--include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
-- ${EIGEN_INCLUDE_DIRS}
-- ${OpenCV_INCLUDE_DIRS}
--)
-+include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
-
- add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
- target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})