summaryrefslogtreecommitdiff
path: root/dev-ros/sound_play/files/test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/sound_play/files/test.patch')
-rw-r--r--dev-ros/sound_play/files/test.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/sound_play/files/test.patch b/dev-ros/sound_play/files/test.patch
new file mode 100644
index 00000000000..e23490a1c3e
--- /dev/null
+++ b/dev-ros/sound_play/files/test.patch
@@ -0,0 +1,26 @@
+commit ecdde483c81fb89e35f025ee3aacba7cd45528ab
+Author: Alexis Ballier <aballier@gentoo.org>
+Date: Fri Dec 4 12:38:42 2015 +0100
+
+ sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.
+
+ https://bugs.gentoo.org/show_bug.cgi?id=567466
+
+diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
+index ada0b07..3f9604c 100644
+--- a/sound_play/CMakeLists.txt
++++ b/sound_play/CMakeLists.txt
+@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
+ catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
+ INCLUDE_DIRS include)
+
+-catkin_add_nosetests(scripts/test)
++if(CATKIN_ENABLE_TESTING)
++ catkin_add_nosetests(scripts/test)
+
+-add_subdirectory(test)
++ add_subdirectory(test)
++endif()
+
+ install(PROGRAMS
+ scripts/playbuiltin.py