summaryrefslogtreecommitdiff
path: root/dev-ruby/bcrypt-ruby
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/Manifest2
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.10.ebuild60
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild62
-rw-r--r--dev-ruby/bcrypt-ruby/metadata.xml8
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-ruby/bcrypt-ruby/Manifest b/dev-ruby/bcrypt-ruby/Manifest
new file mode 100644
index 00000000000..e93d065b5d0
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/Manifest
@@ -0,0 +1,2 @@
+DIST bcrypt-3.1.10.gem 44032 SHA256 86d25b7eaec3db734bf681aa0e3d58e121766d75c849113aeb602549ff3f8e95 SHA512 11e7a1ea28c53d22354abd3891b88c5f58bd8c18611a2964db69e56e5f9b819e5af184423fbd7fb2ebd1fb84b1618fbd043f0bfd62902515a07427846bef607a WHIRLPOOL e27e2dc2b2796aca39359617adb1261064a58d72b7fe30477f1a7b76678794483b8edebff558f18e68807a38634bf3ae65483c68c967c1ad2bb71589bb6df358
+DIST bcrypt-3.1.9.gem 44032 SHA256 10bda421e4423be8c3d719010b56be99a593de4c584737963c98fc939fadef3f SHA512 5fa1bcdff413abc6a36071f670c79b6d76404b3dc9aeb9a032b22e959674763f4d08afcff93211ad5fe56f20f63d8507688135a1878ca8fcf9bb9b33dc17882b WHIRLPOOL d3d477b412193073cff65ebad757c3c83c58939047481e8dd6e8056471daf4467214cde835d1e8430594f21da821921657b3a0b6fe03b40b29cc96c89dee71ed
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.10.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.10.ebuild
new file mode 100644
index 00000000000..abad66a1d74
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_NAME="bcrypt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An easy way to keep your users' passwords secure"
+HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/git ls-files/d' bcrypt.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/mri V=1
+ cp ext/mri/*$(get_modname) lib/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
+Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=bcrypt-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild
new file mode 100644
index 00000000000..0bc5d10773b
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_NAME="bcrypt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An easy way to keep your users' passwords secure"
+HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/git ls-files/d' bcrypt.gemspec || die
+ # Fix tests until RSpec3 is available
+ sed -i -e 's/truthy/true/' -e 's/falsey/false/' spec/bcrypt/password_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/mri V=1
+ cp ext/mri/*$(get_modname) lib/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
+Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=bcrypt-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/bcrypt-ruby/metadata.xml b/dev-ruby/bcrypt-ruby/metadata.xml
new file mode 100644
index 00000000000..a1fa63e7c28
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">codahale/bcrypt-ruby</remote-id>
+ </upstream>
+</pkgmetadata>