summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-xslt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-xslt')
-rw-r--r--dev-ruby/ruby-xslt/Manifest1
-rw-r--r--dev-ruby/ruby-xslt/metadata.xml5
-rw-r--r--dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r2.ebuild47
-rw-r--r--dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r3.ebuild47
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/ruby-xslt/Manifest b/dev-ruby/ruby-xslt/Manifest
new file mode 100644
index 00000000000..627bb7d5690
--- /dev/null
+++ b/dev-ruby/ruby-xslt/Manifest
@@ -0,0 +1 @@
+DIST ruby-xslt-0.9.9.gem 34816 SHA256 7dc7565e90719b5971ef9620f64180848a5d9e983e9abc74d76f7cf1b01a2f72 SHA512 8c23bff3406ae2712663f81fb46525df4938aee5bf85f5497ff33108e4fb0f443ca3389dedbbb9eea233e86e51c24938f699eae2bc62cbf291c04a56a9af36ff WHIRLPOOL a01a8a1cfc94de4455fdebd115eb83d5953977a0d57ac50cbdf6d8a874413744aa1a77fe31cfcab628a9d4cf7bdf45423156bb3ea65e904d598762f9ebd23537
diff --git a/dev-ruby/ruby-xslt/metadata.xml b/dev-ruby/ruby-xslt/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/ruby-xslt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r2.ebuild b/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r2.ebuild
new file mode 100644
index 00000000000..35b18f3a292
--- /dev/null
+++ b/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.rdoc AUTHORS.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby class for processing XSLT"
+HOMEPAGE="http://www.rubyfr.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE=""
+
+DEPEND+=" >=dev-libs/libxslt-1.1.12"
+RDEPEND+=" >=dev-libs/libxslt-1.1.12"
+
+all_ruby_prepare() {
+ # Remove forced -g compiler flag.
+ sed -i -e 's/-g //' ext/xslt_lib/extconf.rb || die
+
+ # One test fails but we have installed this code already for a long
+ # time so this probably isn't a regression. No upstream bug tracker
+ # to report the problem :-(
+ sed -i -e '/test_transformation_error/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/xslt_lib extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/xslt_lib V=1
+ cp ext/xslt_lib/xslt_lib$(get_modname) lib/xml/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I../lib:lib -Ctest test.rb || die
+}
diff --git a/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r3.ebuild b/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r3.ebuild
new file mode 100644
index 00000000000..cc64c6aada5
--- /dev/null
+++ b/dev-ruby/ruby-xslt/ruby-xslt-0.9.9-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.rdoc AUTHORS.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby class for processing XSLT"
+HOMEPAGE="http://www.rubyfr.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" >=dev-libs/libxslt-1.1.12"
+RDEPEND+=" >=dev-libs/libxslt-1.1.12"
+
+all_ruby_prepare() {
+ # Remove forced -g compiler flag.
+ sed -i -e 's/-g //' ext/xslt_lib/extconf.rb || die
+
+ # One test fails but we have installed this code already for a long
+ # time so this probably isn't a regression. No upstream bug tracker
+ # to report the problem :-(
+ sed -i -e '/test_transformation_error/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/xslt_lib extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/xslt_lib V=1
+ cp ext/xslt_lib/xslt_lib$(get_modname) lib/xml/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I../lib:lib -Ctest test.rb || die
+}