summaryrefslogtreecommitdiff
path: root/dev-util/patchelf/patchelf-0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf/patchelf-0.8.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.8.ebuild b/dev-util/patchelf/patchelf-0.8.ebuild
new file mode 100644
index 00000000000..ef8f82a7d79
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-dash.patch )
+
+src_prepare() {
+ rm src/elf.h || die
+ sed -e 's:-Werror::g' -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( --docdir="${EPREFIX}"/usr/share/doc/${PF} )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}