summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index ab8aac7458b..d4bf9a3890b 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -33,7 +33,7 @@ pkg_setup() {
}
python_compile_all() {
- [[ ${PV} == *9999 ]] && emake -C doc man
+ [[ ${PV} == *9999 ]] && esetup.py build_man
}
python_test() {
@@ -42,16 +42,10 @@ python_test() {
python_install_all() {
local DOCS=( AUTHORS NEWS.rst )
+ distutils-r1_python_install install_man
distutils-r1_python_install_all
-
- if [[ ${PV} == *9999 ]]; then
- emake -C doc PREFIX=/usr DESTDIR="${D}" install_man
- else
- doman man/*
- fi
}
pkg_postinst() {
- einfo "updating pkgcore plugin cache"
python_foreach_impl pplugincache pkgcheck.plugins
}