summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-git/hg-git-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.7.0.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.7.0.ebuild b/dev-vcs/hg-git/hg-git-0.7.0.ebuild
new file mode 100644
index 00000000000..89016f56ab0
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-3.3.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"