summaryrefslogtreecommitdiff
path: root/eclass/kde5.eclass
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/kde5.eclass')
-rw-r--r--eclass/kde5.eclass13
1 files changed, 7 insertions, 6 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 60d8f131f1c..71839733485 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -566,17 +566,18 @@ kde5_src_prepare() {
pushd ${po} > /dev/null || die
local lang
for lang in *; do
- if [[ -d ${lang} ]] && ! has ${lang} ${LINGUAS} ; then
- rm -r ${lang} || die
+ if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+ case ${lang} in
+ cmake_modules | \
+ CMakeLists.txt | \
+ ${PN}.pot) ;;
+ *) rm -r ${lang} || die ;;
+ esac
if [[ -e CMakeLists.txt ]] ; then
cmake_comment_add_subdirectory ${lang}
sed -e "/add_subdirectory([[:space:]]*${lang}\/.*[[:space:]]*)/d" \
-i CMakeLists.txt || die
fi
- elif [[ -f ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
- if [[ ${lang} != CMakeLists.txt && ${lang} != ${PN}.pot ]] ; then
- rm ${lang} || die
- fi
fi
done
popd > /dev/null || die