summaryrefslogtreecommitdiff
path: root/games-arcade/openbubbles/openbubbles-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openbubbles/openbubbles-1.2.ebuild')
-rw-r--r--games-arcade/openbubbles/openbubbles-1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-arcade/openbubbles/openbubbles-1.2.ebuild b/games-arcade/openbubbles/openbubbles-1.2.ebuild
new file mode 100644
index 00000000000..434c1926a15
--- /dev/null
+++ b/games-arcade/openbubbles/openbubbles-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A clone of Evan Bailey's game Bubbles"
+HOMEPAGE="http://www.freewebs.com/lasindi/openbubbles/index.html"
+SRC_URI="http://www.freewebs.com/lasindi/openbubbles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-gfx"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-glibc2.10.patch )
+
+src_install() {
+ default
+ newicon data/bubble.png ${PN}.png
+ make_desktop_entry ${PN} "OpenBubbles"
+ prepgamesdirs
+}