summaryrefslogtreecommitdiff
path: root/games-arcade/oshu/oshu-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/oshu/oshu-1.6.0.ebuild')
-rw-r--r--games-arcade/oshu/oshu-1.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-arcade/oshu/oshu-1.6.0.ebuild b/games-arcade/oshu/oshu-1.6.0.ebuild
new file mode 100644
index 00000000000..de03656934d
--- /dev/null
+++ b/games-arcade/oshu/oshu-1.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Lightweight osu! port"
+HOMEPAGE="https://github.com/fmang/oshu"
+SRC_URI="https://www.mg0.fr/oshu/releases/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3 CC-BY-NC-4.0"
+SLOT="0"
+IUSE="libav"
+
+RDEPEND="
+ media-libs/libsdl2:=
+ media-libs/sdl2-image:=
+ x11-libs/cairo:=
+ !libav? ( media-video/ffmpeg:= )
+ libav? ( media-video/libav:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"