summaryrefslogtreecommitdiff
path: root/games-simulation/pmars-sdl
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/pmars-sdl')
-rw-r--r--games-simulation/pmars-sdl/Manifest1
-rw-r--r--games-simulation/pmars-sdl/metadata.xml5
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild87
3 files changed, 93 insertions, 0 deletions
diff --git a/games-simulation/pmars-sdl/Manifest b/games-simulation/pmars-sdl/Manifest
new file mode 100644
index 00000000000..ef42c3aec43
--- /dev/null
+++ b/games-simulation/pmars-sdl/Manifest
@@ -0,0 +1 @@
+DIST pmars-0.9.2-5.tar.gz 200966 SHA256 a8518ec8cc13728dc202c34fe73657123454b9fc76bcddf6b299201143e6fee3 SHA512 197d1967507199ed5eb075fb232a2f15d9bdf4bec03fc6b1d6df5d6259d6627eb40338c5787852ea10d96858029144348128b08e86c7079d96f10fd09dafc315 WHIRLPOOL b588f0381a201b5d3b440626adb8b72ec4b89f68951ce57fd9d4ede604ee2599b5db4443dab18d9dca6c958145515e2f911b9fcd48a8243a841d0276f1b0a581
diff --git a/games-simulation/pmars-sdl/metadata.xml b/games-simulation/pmars-sdl/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-simulation/pmars-sdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
new file mode 100644
index 00000000000..3efe83a1c9d
--- /dev/null
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs games
+
+MY_PN="${PN/-sdl/}"
+MY_PV="${PV/e/-5}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Portable redcode simulator's sdl port for core war"
+HOMEPAGE="http://corewar.co.uk/pihlaja/pmars-sdl/"
+SRC_URI="http://corewar.co.uk/pihlaja/pmars-sdl/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="sdl X"
+
+DEPEND="sdl? ( x11-libs/libX11 media-libs/libsdl[video] )
+ X? ( x11-libs/libX11 )
+ !sdl? ( !X? ( sys-libs/ncurses ) )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ CFLAGS="${CFLAGS} -DEXT94 -DPERMUTATE"
+ LFLAGS="-x"
+
+ if use sdl ; then
+ CFLAGS="${CFLAGS} -DSDLGRAPHX `sdl-config --cflags`"
+ LIB=`sdl-config --libs`
+ elif use X ; then
+ CFLAGS="${CFLAGS} -DXWINGRAPHX"
+ LIB="-L/usr/X11R6/lib -lX11"
+ else
+ CFLAGS="${CFLAGS} -DCURSESGRAPHX"
+ LIB="-lcurses"
+ fi
+
+ cd src
+
+ SRC="asm.c
+ cdb.c
+ clparse.c
+ disasm.c
+ eval.c
+ global.c
+ pmars.c
+ sim.c
+ pos.c
+ str_eng.c
+ token.c"
+
+ for x in ${SRC}; do
+ einfo "compiling ${x}"
+ $(tc-getCC) ${CFLAGS} ${x} -c || die
+ done
+
+ echo
+ einfo "linking with LIB: ${LIB}"
+ $(tc-getCC) ${LDFLAGS} *.o ${LIB} -o ${MY_PN} || die
+}
+
+src_install() {
+ dogamesbin src/${MY_PN}
+ doman doc/${MY_PN}.6
+
+ dodoc AUTHORS CONTRIB ChangeLog README doc/redcode.ref
+
+ insinto "${GAMES_DATADIR}/${MY_PN}/warriors"
+ doins warriors/*
+
+ insinto "${GAMES_DATADIR}/${MY_PN}/macros"
+ doins config/*.mac
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "There are some macros in ${GAMES_DATADIR}/${MY_PN}/macros"
+ ewarn "which you should make accessible to pmars by typing"
+ ewarn "export PMARSHOME=${GAMES_DATADIR}/${MY_PN}/macros\n"
+}