summaryrefslogtreecommitdiff
path: root/kde-apps/cantor
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-17.04.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 8757f9e858d..f7f25081810 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-16.12.3.tar.xz 378460 SHA256 888677129bf30474a2f2bfe46931770f411cf8823c944e90ba4ea16d9d4eefdb SHA512 e6401d5472797894931b4c1c0a4cda7e900ede0d9c5e7d1b5a2ff518741f7f62a7f6187b5081edb231f47c1de163aa537cc195e381334ed60890eb6c73374768 WHIRLPOOL d0dbd031450ed730fdcb382a6aba778e0b9928ada3fe7c144012e95a521d53f1c13fe34bbbc6d2339e10cdf60f464327f9583e1bbbd10c1ecc6f2f43d308df33
DIST cantor-17.04.0.tar.xz 1059812 SHA256 bea7d26f787837808d9371a243a22ed96715331c69086cc9b638d31ae3f3c76f SHA512 0a21383d027b3126b8d3f06f15300fbdb35f32ee61b3b46fb085952cc6f8c2ebd27a220bb2f3c7ee11120defeb56d3e0d2da622f9678b50532b2ecec539c5570 WHIRLPOOL 43d4daf740ee6f89bb3250e9858f69ba3ad5a07176dbf4a35511acd9ff88619c15bead8a2885cedf50b23f14ba7e0c29520994c53139201acc3d21a54daca605
+DIST cantor-17.04.1.tar.xz 1059912 SHA256 81ac140183c18e2d8b68f761526188a7fdcddd9e78f92067a48b442f9a831990 SHA512 d8b871324bca1874e8b29abf9bf5e0c044ffce40a030c94c7a978fd8f887a776a5a6a6de01946a9bbbc13d4da4e1b43a4c1ffb9625bf4d84f3a9fd137ad61163 WHIRLPOOL f53a4078b95c6b8035024a20b1b3b5350980acca4a72a43d4da8addb4f9209bece884eba8bde7cde59c92a85275521313bd5f3d273b3f5cbc1fbd3a851983454
diff --git a/kde-apps/cantor/cantor-17.04.1.ebuild b/kde-apps/cantor/cantor-17.04.1.ebuild
new file mode 100644
index 00000000000..871d6529b36
--- /dev/null
+++ b/kde-apps/cantor/cantor-17.04.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+# FIXME: PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor"
+KEYWORDS="~amd64 ~x86"
+IUSE="analitza julia lua postscript python qalculate +R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ julia? ( dev-lang/julia )
+ lua? ( dev-lang/luajit:2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate:=
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${PN}-16.12.2-bashism.patch )
+
+pkg_pretend() {
+ kde5_pkg_pretend
+
+ if ! has_version sci-mathematics/maxima && ! has_version sci-mathematics/octave && \
+ ! use analitza && ! use julia && ! use lua && ! use python && ! use qalculate && ! use R; then
+ einfo "You have decided to build ${PN} with no backend."
+ einfo "To have this application functional, please enable one of the backends via USE flag:"
+ einfo " analitza, julia, lua, python, qalculate, R"
+ einfo "Alternatively, install one of these:"
+ einfo " # emerge sci-mathematics/maxima"
+ einfo " # emerge sci-mathematics/octave"
+ einfo
+ fi
+
+ if ! has_version virtual/latex-base; then
+ einfo "For LaTeX support:"
+ einfo " # emerge virtual/latex-base"
+ fi
+}
+
+pkg_setup() {
+ use python && python_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
+ sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
+ -i src/backends/CMakeLists.txt || die
+}
+
+src_configure() {
+ use julia && addpredict /proc/self/mem # bug 602894
+
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package julia Julia)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}