summaryrefslogtreecommitdiff
path: root/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/sonnet/sonnet-5.26.0.ebuild')
-rw-r--r--kde-frameworks/sonnet/sonnet-5.26.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/kde-frameworks/sonnet/sonnet-5.26.0.ebuild b/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
deleted file mode 100644
index 27fe13acb1f..00000000000
--- a/kde-frameworks/sonnet/sonnet-5.26.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit kde5
-
-DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
-LICENSE="LGPL-2+ LGPL-2.1+"
-KEYWORDS="amd64 ~arm x86"
-IUSE="aspell +hunspell nls"
-
-RDEPEND="
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell:= )
-"
-DEPEND="${RDEPEND}
- nls? ( $(add_qt_dep linguist-tools) )
-"
-
-src_prepare() {
- kde5_src_prepare
-
- # ensure at least one version-free atom so that hunspell is found
- sed -e "/FIND_LIBRARY(HUNSPELL_LIBRARIES/ s/\bhunspell\b-[0-9.]*/hunspell/" \
- -i cmake/FindHUNSPELL.cmake || die
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package aspell ASPELL)
- $(cmake-utils_use_find_package hunspell HUNSPELL)
- )
-
- kde5_src_configure
-}