summaryrefslogtreecommitdiff
path: root/lxqt-base/liblxqt/liblxqt-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/liblxqt/liblxqt-0.9.0.ebuild')
-rw-r--r--lxqt-base/liblxqt/liblxqt-0.9.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-0.9.0.ebuild b/lxqt-base/liblxqt/liblxqt-0.9.0.ebuild
deleted file mode 100644
index e51251a8e58..00000000000
--- a/lxqt-base/liblxqt/liblxqt-0.9.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="Common base library for the LXQt desktop environment"
-HOMEPAGE="http://lxqt.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
-else
- SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="GPL-2 LGPL-2.1+"
-SLOT="0"
-
-RDEPEND=">=dev-libs/libqtxdg-1.0.0
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-qt/qtxml:5
- kde-frameworks/kwindowsystem:5
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-PATCHES=( "${FILESDIR}/${P}-qt55.patch" )
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-version) < 4.8 ]] && \
- die 'The active compiler needs to be gcc 4.8 (or newer)'
- fi
-}