summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild')
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild
deleted file mode 100644
index 087737006bb..00000000000
--- a/lxqt-base/lxqt-panel/lxqt-panel-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils
-
-DESCRIPTION="LXQt desktop panel and plugins"
-HOMEPAGE="http://lxqt.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
-else
- SRC_URI="http://downloads.lxqt.org/lxqt/lxqt/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
- S=${WORKDIR}
-fi
-
-LICENSE="GPL-2 LGPL-2.1+"
-SLOT="0"
-IUSE="+alsa +clock colorpicker cpuload +desktopswitch dom +kbindicator +mainmenu
- +mount networkmonitor pulseaudio +quicklaunch screensaver sensors
- +showdesktop sysstat +taskbar teatime +tray +volume worldclock"
-REQUIRED_USE="volume? ( || ( alsa pulseaudio ) )"
-
-DEPEND="dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- >=lxde-base/menu-cache-0.3.3
- ~lxqt-base/liblxqt-${PV}
- ~lxqt-base/liblxqt-mount-${PV}
- ~lxqt-base/lxqt-globalkeys-${PV}
- ~dev-libs/libqtxdg-0.5.3
- x11-libs/libX11
- cpuload? ( sys-libs/libstatgrab )
- networkmonitor? ( sys-libs/libstatgrab )
- sensors? ( sys-apps/lm_sensors )
- sysstat? ( ~lxqt-base/libsysstat-0.1.0 )
- volume? ( alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio ) )
- worldclock? ( dev-libs/icu:= )"
-RDEPEND="${DEPEND}
- lxde-base/lxmenu-data"
-
-src_configure() {
- local mycmakeargs i y
- for i in clock colorpicker cpuload desktopswitch dom kbindicator mainmenu mount \
- networkmonitor quicklaunch screensaver sensors showdesktop sysstat \
- taskbar teatime tray volume worldclock; do
- y=$(tr '[:lower:]' '[:upper:]' <<< "${i}")
- mycmakeargs+=( $(cmake-utils_use ${i} ${y}_PLUGIN) )
- done
-
- if use volume; then
- mycmakeargs+=( $(cmake-utils_use alsa VOLUME_USE_ALSA)
- $(cmake-utils_use pulseaudio VOLUME_USE_PULSEAUDIO) )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install(){
- cmake-utils_src_install
- doman panel/man/*.1
-}