summaryrefslogtreecommitdiff
path: root/mail-filter/ask
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/ask')
-rw-r--r--mail-filter/ask/Manifest2
-rw-r--r--mail-filter/ask/ask-2.4.1.ebuild57
-rw-r--r--mail-filter/ask/ask-2.5.3.ebuild42
-rw-r--r--mail-filter/ask/metadata.xml12
4 files changed, 113 insertions, 0 deletions
diff --git a/mail-filter/ask/Manifest b/mail-filter/ask/Manifest
new file mode 100644
index 00000000000..8ebad0876d0
--- /dev/null
+++ b/mail-filter/ask/Manifest
@@ -0,0 +1,2 @@
+DIST ask-2.4.1.tar.gz 102631 SHA256 1b5aedca6ff52cb6067f07ca6f8766e86ab4dd2b19585a3e4221c01cc50f147d
+DIST ask-2.5.3.tar.gz 106339 SHA256 f5f90d9006f655673104d45f803a6e7e1f9baba708a51510cf16e5e753183f15
diff --git a/mail-filter/ask/ask-2.4.1.ebuild b/mail-filter/ask/ask-2.4.1.ebuild
new file mode 100644
index 00000000000..3cdfa73cd09
--- /dev/null
+++ b/mail-filter/ask/ask-2.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Active Spam Killer: A program to filter spam"
+HOMEPAGE="http://www.paganini.net/ask/index.html"
+SRC_URI="mirror://sourceforge/a-s-k/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+
+IUSE="procmail"
+RDEPEND=">=dev-lang/python-2.2
+ virtual/mta
+ procmail? ( >=mail-filter/procmail-3.22 )"
+
+src_install() {
+ into /
+ dobin ask.py asksetup.py askversion.py utils/asksenders.py
+
+ insinto /usr/lib/ask
+ doins askconfig.py asklock.py asklog.py askmail.py askmain.py \
+ askmessage.py askremote.py
+
+ insinto /usr/share/ask/samples
+ doins samples/*
+
+ insinto /usr/share/ask/templates
+ doins templates/*
+
+ insinto /usr/share/ask/utils
+ doins utils/*
+
+ doman docs/*.1
+
+ dodoc ChangeLog TODO docs/ask_doc*
+}
+
+pkg_postinst() {
+ elog
+ elog "You MUST run the asksetup.py file to configure ASK!"
+ elog
+ if use procmail; then
+ elog "To use ASK's procmail support these should be your first two procmail rules:"
+ elog
+ elog ":0 fW"
+ elog "|/path_to_ask/ask.py --procmail --loglevel=5 --logfile=/your_home/ask.log"
+ elog
+ elog ":0 e"
+ elog "/dev/null"
+ elog
+ elog "The second rule above instructs procmail to deliver the message to /dev/null"
+ elog "if ASK returns a fail code. If you're truly paranoid, you can save those"
+ elog "messages to a file instead for later inspection."
+ fi
+}
diff --git a/mail-filter/ask/ask-2.5.3.ebuild b/mail-filter/ask/ask-2.5.3.ebuild
new file mode 100644
index 00000000000..72c30d90560
--- /dev/null
+++ b/mail-filter/ask/ask-2.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib
+
+DESCRIPTION="Active Spam Killer: A program to filter spam"
+HOMEPAGE="http://www.paganini.net/ask/index.html"
+SRC_URI="mirror://sourceforge/a-s-k/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="procmail"
+RDEPEND="dev-lang/python
+ virtual/mta
+ procmail? ( >=mail-filter/procmail-3.22 )"
+
+src_install() {
+ dobin askfilter asksetup askversion.py utils/asksenders
+
+ insinto /usr/$(get_libdir)/ask
+ doins askconfig.py asklock.py asklog.py askmail.py askmain.py \
+ askmessage.py askremote.py
+
+ insinto /usr/share/ask/templates
+ doins templates/*
+
+ insinto /usr/share/ask/utils
+ doins utils/*
+
+ doman docs/*.1
+
+ dodoc ChangeLog docs/ask_doc*
+}
+
+pkg_postinst() {
+ elog "You MUST run the asksetup file to configure ASK!"
+ elog "WARNING: if you upgrade from ask-2.4.1, you must replace ask.py with askfilter"
+ elog " in your procmail/maildrop recipe!"
+}
diff --git a/mail-filter/ask/metadata.xml b/mail-filter/ask/metadata.xml
new file mode 100644
index 00000000000..6e7a699e30a
--- /dev/null
+++ b/mail-filter/ask/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="procmail">Adds support for
+ <pkg>mail-filter/procmail</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">a-s-k</remote-id>
+ </upstream>
+</pkgmetadata>