summaryrefslogtreecommitdiff
path: root/media-libs/sdl2-gfx
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl2-gfx')
-rw-r--r--media-libs/sdl2-gfx/Manifest1
-rw-r--r--media-libs/sdl2-gfx/metadata.xml18
-rw-r--r--media-libs/sdl2-gfx/sdl2-gfx-1.0.1.ebuild40
3 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/sdl2-gfx/Manifest b/media-libs/sdl2-gfx/Manifest
new file mode 100644
index 00000000000..6adbe161cad
--- /dev/null
+++ b/media-libs/sdl2-gfx/Manifest
@@ -0,0 +1 @@
+DIST SDL2_gfx-1.0.1.tar.gz 1078780 SHA256 d69bcbceb811b4e5712fbad3ede737166327f44b727f1388c32581dbbe8c599a SHA512 413f0ac8a60b6c4c91f154dd72a512f410e134642fefb80cd3482646c9aab7dd56d2cc9015e78ee59b5bc89adc7397a248fe2132077c004114ad6505ca4194de WHIRLPOOL e16f899bfd94ad0959bc156f43ce2f149e8e4bbd0f2b4bfba643ff109df030f9120262fa6accc7eca15c090f3c63e50f46ab215760f18bc2ce4af663bdbd0320
diff --git a/media-libs/sdl2-gfx/metadata.xml b/media-libs/sdl2-gfx/metadata.xml
new file mode 100644
index 00000000000..a2c38b643e9
--- /dev/null
+++ b/media-libs/sdl2-gfx/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ The SDL2_gfx library provides the basic drawing functions such
+ as lines, circles or polygons provided by SDL_gfx on SDL2 against
+ renderers of SDL2.
+
+ The current components of the SDL2_gfx library are:
+
+ * Graphic Primitives (SDL_gfxPrimitives.h, SDL_gfxPrimitives.c)
+ * Surface Rotozoomer (SDL_rotozoom.h, SDL_rotozoom.c)
+ * Framerate control (SDL_framerate.h, SDL_framerate.c)
+ * MMX image filters (SDL_imageFilter.h, SDL_imageFilter.c)
+ * Build-in 8x8 Font (SDL_gfxPrimitives_font.h)
+ </longdescription>
+</pkgmetadata>
diff --git a/media-libs/sdl2-gfx/sdl2-gfx-1.0.1.ebuild b/media-libs/sdl2-gfx/sdl2-gfx-1.0.1.ebuild
new file mode 100644
index 00000000000..2600c47e3f9
--- /dev/null
+++ b/media-libs/sdl2-gfx/sdl2-gfx-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+MY_P="${P/sdl2-/SDL2_}"
+DESCRIPTION="Graphics drawing primitives library for SDL2"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL2_gfx/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc cpu_flags_x86_mmx static-libs"
+
+DEPEND=">=media-libs/libsdl2-2.0.1-r1[video,${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e 's/ -O / /' \
+ configure.in || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ use doc && dohtml -r Docs/html/*
+ prune_libtool_files
+}