summaryrefslogtreecommitdiff
path: root/media-libs/vo-amrwbenc
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vo-amrwbenc')
-rw-r--r--media-libs/vo-amrwbenc/Manifest2
-rw-r--r--media-libs/vo-amrwbenc/metadata.xml15
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2-r1.ebuild41
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild41
-rw-r--r--media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild41
5 files changed, 140 insertions, 0 deletions
diff --git a/media-libs/vo-amrwbenc/Manifest b/media-libs/vo-amrwbenc/Manifest
new file mode 100644
index 00000000000..0888418229d
--- /dev/null
+++ b/media-libs/vo-amrwbenc/Manifest
@@ -0,0 +1,2 @@
+DIST vo-amrwbenc-0.1.2.tar.gz 598415 SHA256 dd8c33e57bc415754f31fbb1b1536563bf731fc14e55f8182564e4c0fbb26435 SHA512 54be9c63d1b4c66e56dbf85cef2924c4cc564556186692182b44f199a5f72eba02c619b8cfa89f33b88add149fded81a42a392a9b96b6274ad0ad6c1f929a61b WHIRLPOOL bde8f79f722e6e997bbef1e85f279069a722153c58078c39c8dfbb43432ead98661c4107be4777bcd1b5a69407c5648d27fece8d981a47eb358c958f265df214
+DIST vo-amrwbenc-0.1.3.tar.gz 608936 SHA256 5652b391e0f0e296417b841b02987d3fd33e6c0af342c69542cbb016a71d9d4e SHA512 5f132f798f00ec2c0619700ab1ce456897792b45631af4b538c866636af9c9de5600af5f79040c41c3dc69c17cf4be7032139a9518a46a4276431e091f3dd6a9 WHIRLPOOL e4d10c0a9504ea27a515efb2d96428eea4c6a0c879c4377a37026c217a60515747e1616dff7da9222c1a8d263f6d106370d3fe7edc05d3fe547960ac4f24579d
diff --git a/media-libs/vo-amrwbenc/metadata.xml b/media-libs/vo-amrwbenc/metadata.xml
new file mode 100644
index 00000000000..6d37ec54497
--- /dev/null
+++ b/media-libs/vo-amrwbenc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+VisualOn AMR-WB encoder library
+This library contains an encoder implementation of the Adaptive Multi
+Rate Wideband (AMR-WB) audio codec. The library is based on a codec
+implementation by VisualOn, part of the Stagefright framework from
+the Google Android project.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">opencore-amr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2-r1.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2-r1.ebuild
new file mode 100644
index 00000000000..02ccc4ca492
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples example) \
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild
new file mode 100644
index 00000000000..ed68c3a6bc8
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-0.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples example) \
+ )
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
new file mode 100644
index 00000000000..f28f12086d3
--- /dev/null
+++ b/media-libs/vo-amrwbenc/vo-amrwbenc-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AMR-WB encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples example) \
+ )
+ autotools-multilib_src_configure
+}