summaryrefslogtreecommitdiff
path: root/media-tv/gentoo-vdr-scripts
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/gentoo-vdr-scripts')
-rw-r--r--media-tv/gentoo-vdr-scripts/Manifest5
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.0.0.ebuild131
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.5.ebuild134
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.2.ebuild136
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.3.ebuild136
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.ebuild136
-rw-r--r--media-tv/gentoo-vdr-scripts/metadata.xml12
7 files changed, 690 insertions, 0 deletions
diff --git a/media-tv/gentoo-vdr-scripts/Manifest b/media-tv/gentoo-vdr-scripts/Manifest
new file mode 100644
index 00000000000..b057b8ec9fd
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/Manifest
@@ -0,0 +1,5 @@
+DIST gentoo-vdr-scripts-2.0.0.tar.bz2 37438 SHA256 6c2025714546a25632c5b8103b3fa4b7ca6adf963189800c91e99cb23f7b2a79 SHA512 0214b390e1e4fe4f65ceb940a1d092f88fe5263eda3c97ebfa7d2925a772165af3a3c62bfc964e577e374ce723aefccb29082f8219fda918ad17f966ad8ad392 WHIRLPOOL a3de83d95a51622de997d8231b973d6899a2fa21324492e11eb4001ad3c15dee5c6e65f20ee44fd43ebe2974b2b1acf623956d2d44b955bfee799d1a696ace65
+DIST gentoo-vdr-scripts-2.5.tar.bz2 39893 SHA256 39a3c5d1cf30f1b07a6218b2154835994bbf9d65358e916260bad970a6ca6432 SHA512 bed3db4e3c4f8195d5715d274a32485d067fa2e539ace417c2d73bac1294d46736754be589d5e18b77e0baa1b4d9cd7df5ff8a13db2850d92d2eb992f9b131a6 WHIRLPOOL 5a7626484784ad49624df92daab0997368f885d4d5f6ad732082c2a77c840f6e23f345cf35816890d43493c57fa70c90eb9a4ab785a8d4ead81f6779714138b9
+DIST gentoo-vdr-scripts-2.7.2.tar.bz2 48584 SHA256 65de19d3738442a08cdb603ab0e0116e96bbcd8d58b9c9b3f2942e0bcb5365cb SHA512 cb0297c7e78e4c110097d1c08a5f6642d8194d01dd47308f7a41c6d76f7b1675cc612d47a7725eb4f47a393086b034ca09703af0867ae02a36af4be12701f861 WHIRLPOOL 7fe4e106512cca4e26a778320cadf93976897622dac2fd2cf7e21e20e44da27caa69da71f7a779747bc05872e6b90ee7440a7c8fbd2165e6c6a2544804c71da1
+DIST gentoo-vdr-scripts-2.7.3.tar.bz2 49156 SHA256 a8fb04ca737080dd4fa4d300243d833f835885c0b4c9ca3f1808997713a626ec SHA512 9d00acaf77bbbf52f4a4d4b8284d94b9d191c354de52ea6f7bba0751be661feec4915cca20be3d24a0471efe4b3f24c5dcc025e3e8b0cc6b2c37f8843b91a520 WHIRLPOOL bd30b36284754d4e5c135c381e4114354b1292f4203d0367622c650252d8ecbcaabe58bc40b4d0ad26b54553f5ee0ff5e2e32e13abdd088bd26b0b41a97ee10c
+DIST gentoo-vdr-scripts-2.7.tar.bz2 46618 SHA256 40f6e50e684b4dde9c026887119e80c9680212bfe41854c6526cc1346c0ae2a2 SHA512 95db4d2632d07cc86394fbc2898050d47175f01cc60b61230ba5363c770ba6ad5c5935987ac6a1131bc575887633ed6c8f6242f7de225fc875d0871123665bc5 WHIRLPOOL 889e2379fa9df6ae9992f6569779d4f485488e84c9c1065c43717ae07d15c601ce9a731e612e6bfaaf7df55d5eb4c7901f16bbf0eff680bc5b4ea25662885790
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.0.0.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.0.0.ebuild
new file mode 100644
index 00000000000..fa8adcd6241
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.0.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils user
+
+DESCRIPTION="Scripts necessary for use of vdr as a set-top-box"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="nvram"
+
+RDEPEND="nvram? ( sys-power/nvram-wakeup )
+ app-admin/sudo
+ sys-process/wait_on_pid"
+
+VDR_HOME=/var/vdr
+
+pkg_setup() {
+ enewgroup vdr
+
+ # Add user vdr to these groups:
+ # video - accessing dvb-devices
+ # audio - playing sound when using software-devices
+ # cdrom - playing dvds/audio-cds ...
+ enewuser vdr -1 /bin/bash "${VDR_HOME}" vdr,video,audio,cdrom
+}
+
+src_prepare() {
+ # moved into own package
+ sed -e '/SUBDIRS =/s# bin # #' -i usr/Makefile
+ sed -e '/all:/s#compile##' -i Makefile
+}
+
+src_install() {
+ emake -s install DESTDIR="${D}" || die "make install failed"
+ dodoc README TODO ChangeLog README.grub2
+
+ # create necessary directories
+ diropts -ovdr -gvdr
+ keepdir "${VDR_HOME}"
+
+ local kd
+ for kd in shutdown-data merged-config-files dvd-images tmp; do
+ keepdir "${VDR_HOME}/${kd}"
+ done
+}
+
+pkg_preinst() {
+ local PLUGINS_NEW=0
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.plugins ]]; then
+ PLUGINS_NEW=$(grep -v '^#' "${ROOT}"/etc/conf.d/vdr.plugins |grep -v '^$'|wc -l)
+ fi
+ if [[ ${PLUGINS_NEW} > 0 ]]; then
+ cp "${ROOT}"/etc/conf.d/vdr.plugins "${D}"/etc/conf.d/vdr.plugins
+ else
+ einfo "Migrating PLUGINS setting from /etc/conf.d/vdr to /etc/conf.d/vdr.plugins"
+ local PLUGIN
+ for PLUGIN in $(source "${ROOT}"/etc/conf.d/vdr;echo $PLUGINS); do
+ echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
+ done
+ fi
+
+ has_version "<${CATEGORY}/${PN}-0.5.4"
+ previous_less_than_0_5_4=$?
+}
+
+VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_5_4 = 0 ]] ; then
+ einfo "\nVDR use now default the --cachedir parameter to store the epg.file"
+ einfo "Please do not override this with the EPGFILE variable\n"
+
+ einfo "svdrp port 2001 support removed\n"
+
+ einfo "--rcu support removed, use media-plugin/vdr-rcu\n"
+ fi
+
+ elog "nvram wakeup is optional."
+ elog "To make use of it emerge sys-power/nvram-wakeup."
+ elog
+
+ elog "Plugins which should be used are now set via its"
+ elog "own config-file called /etc/conf.d/vdr.plugins"
+ elog "or enabled via the frontend eselect vdr-plugin."
+ elog
+
+ if [[ -f "${ROOT}/etc/init.d/dvbsplash" ]]; then
+ ewarn
+ ewarn "You have dvbsplash installed!"
+ ewarn "/etc/init.d/dvbsplash will now be deleted"
+ ewarn "as it causes difficult to debug problems."
+ ewarn
+ rm "${ROOT}/etc/init.d/dvbsplash"
+ fi
+
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.dvdswitch ]] &&
+ grep -q ^DVDSWITCH_BURNSPEED= "${ROOT}"/etc/conf.d/vdr.dvdswitch
+ then
+ ewarn "You are setting DVDSWITCH_BURNSPEED in /etc/conf.d/vdr.dvdswitch"
+ ewarn "This no longer has any effect, please use"
+ ewarn "VDR_DVDBURNSPEED in /etc/conf.d/vdr.cd-dvd"
+ fi
+}
+
+pkg_config() {
+ if grep -q /usr/share/vdr/bin/vdrshutdown-really.sh "${ROOT}"/etc/sudoers; then
+
+ einfo "Removing depricated entry from /etc/sudoers:"
+ einfo "- ${VDRSUDOENTRY}"
+
+ cd "${T}"
+ cat >sudoedit-vdr.sh <<-SUDOEDITOR
+ #!/bin/bash
+ sed -i \${1} -e '/\/usr\/share\/vdr\/bin\/vdrshutdown-really.sh *$/d'
+
+ SUDOEDITOR
+ chmod a+x sudoedit-vdr.sh
+
+ VISUAL="${T}"/sudoedit-vdr.sh visudo -f "${ROOT}"/etc/sudoers || die "visudo failed"
+
+ einfo "Edited /etc/sudoers"
+ fi
+}
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.5.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.5.ebuild
new file mode 100644
index 00000000000..aeee417052b
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Scripts necessary for use of vdr as a set-top-box"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="nvram"
+
+RDEPEND="nvram? ( sys-power/nvram-wakeup )
+ app-admin/sudo
+ sys-process/wait_on_pid"
+
+VDR_HOME=/var/vdr
+
+pkg_setup() {
+ enewgroup vdr
+
+ # Add user vdr to these groups:
+ # video - accessing dvb-devices
+ # audio - playing sound when using software-devices
+ # cdrom - playing dvds/audio-cds ...
+ enewuser vdr -1 /bin/bash "${VDR_HOME}" vdr,video,audio,cdrom
+}
+
+src_prepare() {
+ # moved into own package
+ sed -e '/SUBDIRS =/s# bin # #' -i usr/Makefile
+ sed -e '/all:/s#compile##' -i Makefile
+}
+
+src_install() {
+ emake -s install DESTDIR="${D}" || die "make install failed"
+ dodoc README TODO ChangeLog README.grub2 README.shutdown README.shutdown-jobs README.systemd README.vdrcaps
+
+ # create necessary directories
+ diropts -ovdr -gvdr
+ keepdir "${VDR_HOME}"
+
+ local kd
+ for kd in shutdown-data merged-config-files dvd-images tmp; do
+ keepdir "${VDR_HOME}/${kd}"
+ done
+}
+
+pkg_preinst() {
+ local PLUGINS_NEW=0
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.plugins ]]; then
+ PLUGINS_NEW=$(grep -v '^#' "${ROOT}"/etc/conf.d/vdr.plugins |grep -v '^$'|wc -l)
+ fi
+ if [[ ${PLUGINS_NEW} > 0 ]]; then
+ cp "${ROOT}"/etc/conf.d/vdr.plugins "${D}"/etc/conf.d/vdr.plugins
+ else
+ einfo "Migrating PLUGINS setting from /etc/conf.d/vdr to /etc/conf.d/vdr.plugins"
+ local PLUGIN
+ for PLUGIN in $(source "${ROOT}"/etc/conf.d/vdr;echo $PLUGINS); do
+ echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
+ done
+ fi
+
+ has_version "<${CATEGORY}/${PN}-0.5.4"
+ previous_less_than_0_5_4=$?
+}
+
+VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_5_4 = 0 ]] ; then
+ einfo "\nVDR use now default the --cachedir parameter to store the epg.file"
+ einfo "Please do not override this with the EPGFILE variable\n"
+
+ einfo "svdrp port 2001 support removed\n"
+
+ einfo "--rcu support removed, use media-plugin/vdr-rcu\n"
+ fi
+
+ elog "nvram wakeup is optional."
+ elog "To make use of it emerge sys-power/nvram-wakeup."
+ elog
+
+ elog "Plugins which should be used are now set via its"
+ elog "own config-file called /etc/conf.d/vdr.plugins"
+ elog "or enabled via the frontend eselect vdr-plugin."
+ elog
+
+ if [[ -f "${ROOT}/etc/init.d/dvbsplash" ]]; then
+ ewarn
+ ewarn "You have dvbsplash installed!"
+ ewarn "/etc/init.d/dvbsplash will now be deleted"
+ ewarn "as it causes difficult to debug problems."
+ ewarn
+ rm "${ROOT}/etc/init.d/dvbsplash"
+ fi
+
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.dvdswitch ]] &&
+ grep -q ^DVDSWITCH_BURNSPEED= "${ROOT}"/etc/conf.d/vdr.dvdswitch
+ then
+ ewarn "You are setting DVDSWITCH_BURNSPEED in /etc/conf.d/vdr.dvdswitch"
+ ewarn "This no longer has any effect, please use"
+ ewarn "VDR_DVDBURNSPEED in /etc/conf.d/vdr.cd-dvd"
+ fi
+
+ einfo "systemd is now supported by gentoo-vdr-scripts"
+ einfo "Please read for detailed info on this vdr's README.systemd"
+}
+
+pkg_config() {
+ if grep -q /usr/share/vdr/bin/vdrshutdown-really.sh "${ROOT}"/etc/sudoers; then
+
+ einfo "Removing depricated entry from /etc/sudoers:"
+ einfo "- ${VDRSUDOENTRY}"
+
+ cd "${T}"
+ cat >sudoedit-vdr.sh <<-SUDOEDITOR
+ #!/bin/bash
+ sed -i \${1} -e '/\/usr\/share\/vdr\/bin\/vdrshutdown-really.sh *$/d'
+
+ SUDOEDITOR
+ chmod a+x sudoedit-vdr.sh
+
+ VISUAL="${T}"/sudoedit-vdr.sh visudo -f "${ROOT}"/etc/sudoers || die "visudo failed"
+
+ einfo "Edited /etc/sudoers"
+ fi
+}
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.2.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.2.ebuild
new file mode 100644
index 00000000000..ffda950af11
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.2.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Scripts necessary for use of vdr as a set-top-box"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="nvram"
+
+RDEPEND="nvram? ( sys-power/nvram-wakeup )
+ app-admin/sudo
+ sys-process/wait_on_pid"
+
+VDR_HOME=/var/vdr
+
+pkg_setup() {
+ enewgroup vdr
+
+ # Add user vdr to these groups:
+ # video - accessing dvb-devices
+ # audio - playing sound when using software-devices
+ # cdrom - playing dvds/audio-cds ...
+ enewuser vdr -1 /bin/bash "${VDR_HOME}" vdr,video,audio,cdrom
+}
+
+src_prepare() {
+ # moved into own package
+ sed -e '/SUBDIRS =/s# bin # #' -i usr/Makefile
+ sed -e '/all:/s#compile##' -i Makefile
+}
+
+src_install() {
+ default
+ dodoc README* TODO ChangeLog
+
+ # create necessary directories
+ diropts -ovdr -gvdr
+ keepdir "${VDR_HOME}"
+
+ local kd
+ for kd in shutdown-data merged-config-files dvd-images; do
+ keepdir "${VDR_HOME}/${kd}"
+ done
+}
+
+pkg_preinst() {
+ local PLUGINS_NEW=0
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.plugins ]]; then
+ PLUGINS_NEW=$(grep -v '^#' "${ROOT}"/etc/conf.d/vdr.plugins |grep -v '^$'|wc -l)
+ fi
+ if [[ ${PLUGINS_NEW} > 0 ]]; then
+ cp "${ROOT}"/etc/conf.d/vdr.plugins "${D}"/etc/conf.d/vdr.plugins
+ else
+ einfo "Migrating PLUGINS setting from /etc/conf.d/vdr to /etc/conf.d/vdr.plugins"
+ local PLUGIN
+ for PLUGIN in $(source "${ROOT}"/etc/conf.d/vdr;echo $PLUGINS); do
+ echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
+ done
+ fi
+
+ has_version "<${CATEGORY}/${PN}-0.5.4"
+ previous_less_than_0_5_4=$?
+
+ has_version "<${CATEGORY}/${PN}-2.6"
+ previous_less_than_2_6=$?
+}
+
+VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_5_4 = 0 ]] ; then
+ elog "\nVDR use now default the --cachedir parameter to store the epg.file"
+ elog "Please do not override this with the EPGFILE variable\n"
+
+ elog "svdrp port 2001 support removed\n"
+
+ elog "--rcu support removed, use media-plugin/vdr-rcu\n"
+ fi
+
+ if [[ $previous_less_than_2_6 = 0 ]]; then
+ elog "${CATEGORY}/${PN} supports now a init script"
+ elog "to start a X server"
+ elog "Please refer for detailed info to"
+ elog "${CATGORY}/${PN} README.x11-setup\n"
+ fi
+
+ if use nvram; then
+ elog "nvram wakeup is optional."
+ elog "To make use of it emerge sys-power/nvram-wakeup.\n"
+ fi
+
+ elog "Plugins which should be used are now set via its"
+ elog "own config-file called /etc/conf.d/vdr.plugins"
+ elog "or enabled via the frontend eselect vdr-plugin.\n"
+
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.dvdswitch ]] &&
+ grep -q ^DVDSWITCH_BURNSPEED= "${ROOT}"/etc/conf.d/vdr.dvdswitch
+ then
+ ewarn "You are setting DVDSWITCH_BURNSPEED in /etc/conf.d/vdr.dvdswitch"
+ ewarn "This no longer has any effect, please use"
+ ewarn "VDR_DVDBURNSPEED in /etc/conf.d/vdr.cd-dvd"
+ fi
+
+ elog "systemd is supported by ${CATEGORY}/${PN}"
+ elog "Please read for detailed info on this"
+ elog "${CATEGORY}/${PN} README.systemd"
+}
+
+pkg_config() {
+ if grep -q /usr/share/vdr/bin/vdrshutdown-really.sh "${ROOT}"/etc/sudoers; then
+
+ einfo "Removing depricated entry from /etc/sudoers:"
+ einfo "- ${VDRSUDOENTRY}"
+
+ cd "${T}"
+ cat >sudoedit-vdr.sh <<-SUDOEDITOR
+ #!/bin/bash
+ sed -i \${1} -e '/\/usr\/share\/vdr\/bin\/vdrshutdown-really.sh *$/d'
+
+ SUDOEDITOR
+ chmod a+x sudoedit-vdr.sh
+
+ VISUAL="${T}"/sudoedit-vdr.sh visudo -f "${ROOT}"/etc/sudoers || die "visudo failed"
+
+ einfo "Edited /etc/sudoers"
+ fi
+}
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.3.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.3.ebuild
new file mode 100644
index 00000000000..fbc19e2196a
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Scripts necessary for use of vdr as a set-top-box"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="nvram"
+
+RDEPEND="nvram? ( sys-power/nvram-wakeup )
+ app-admin/sudo
+ sys-process/wait_on_pid"
+
+VDR_HOME=/var/vdr
+
+pkg_setup() {
+ enewgroup vdr
+
+ # Add user vdr to these groups:
+ # video - accessing dvb-devices
+ # audio - playing sound when using software-devices
+ # cdrom - playing dvds/audio-cds ...
+ enewuser vdr -1 /bin/bash "${VDR_HOME}" vdr,video,audio,cdrom
+}
+
+src_prepare() {
+ # moved into own package
+ sed -e '/SUBDIRS =/s# bin # #' -i usr/Makefile
+ sed -e '/all:/s#compile##' -i Makefile
+}
+
+src_install() {
+ default
+ dodoc README* TODO ChangeLog
+
+ # create necessary directories
+ diropts -ovdr -gvdr
+ keepdir "${VDR_HOME}"
+
+ local kd
+ for kd in shutdown-data merged-config-files dvd-images; do
+ keepdir "${VDR_HOME}/${kd}"
+ done
+}
+
+pkg_preinst() {
+ local PLUGINS_NEW=0
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.plugins ]]; then
+ PLUGINS_NEW=$(grep -v '^#' "${ROOT}"/etc/conf.d/vdr.plugins |grep -v '^$'|wc -l)
+ fi
+ if [[ ${PLUGINS_NEW} > 0 ]]; then
+ cp "${ROOT}"/etc/conf.d/vdr.plugins "${D}"/etc/conf.d/vdr.plugins
+ else
+ einfo "Migrating PLUGINS setting from /etc/conf.d/vdr to /etc/conf.d/vdr.plugins"
+ local PLUGIN
+ for PLUGIN in $(source "${ROOT}"/etc/conf.d/vdr;echo $PLUGINS); do
+ echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
+ done
+ fi
+
+ has_version "<${CATEGORY}/${PN}-0.5.4"
+ previous_less_than_0_5_4=$?
+
+ has_version "<${CATEGORY}/${PN}-2.6"
+ previous_less_than_2_6=$?
+}
+
+VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_5_4 = 0 ]] ; then
+ elog "\nVDR use now default the --cachedir parameter to store the epg.file"
+ elog "Please do not override this with the EPGFILE variable\n"
+
+ elog "svdrp port 2001 support removed\n"
+
+ elog "--rcu support removed, use media-plugin/vdr-rcu\n"
+ fi
+
+ if [[ $previous_less_than_2_6 = 0 ]]; then
+ elog "${CATEGORY}/${PN} supports now a init script"
+ elog "to start a X server"
+ elog "Please refer for detailed info to"
+ elog "${CATGORY}/${PN} README.x11-setup\n"
+ fi
+
+ if use nvram; then
+ elog "nvram wakeup is optional."
+ elog "To make use of it emerge sys-power/nvram-wakeup.\n"
+ fi
+
+ elog "Plugins which should be used are now set via its"
+ elog "own config-file called /etc/conf.d/vdr.plugins"
+ elog "or enabled via the frontend eselect vdr-plugin.\n"
+
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.dvdswitch ]] &&
+ grep -q ^DVDSWITCH_BURNSPEED= "${ROOT}"/etc/conf.d/vdr.dvdswitch
+ then
+ ewarn "You are setting DVDSWITCH_BURNSPEED in /etc/conf.d/vdr.dvdswitch"
+ ewarn "This no longer has any effect, please use"
+ ewarn "VDR_DVDBURNSPEED in /etc/conf.d/vdr.cd-dvd"
+ fi
+
+ elog "systemd is supported by ${CATEGORY}/${PN}"
+ elog "Please read for detailed info on this"
+ elog "${CATEGORY}/${PN} README.systemd"
+}
+
+pkg_config() {
+ if grep -q /usr/share/vdr/bin/vdrshutdown-really.sh "${ROOT}"/etc/sudoers; then
+
+ einfo "Removing depricated entry from /etc/sudoers:"
+ einfo "- ${VDRSUDOENTRY}"
+
+ cd "${T}"
+ cat >sudoedit-vdr.sh <<-SUDOEDITOR
+ #!/bin/bash
+ sed -i \${1} -e '/\/usr\/share\/vdr\/bin\/vdrshutdown-really.sh *$/d'
+
+ SUDOEDITOR
+ chmod a+x sudoedit-vdr.sh
+
+ VISUAL="${T}"/sudoedit-vdr.sh visudo -f "${ROOT}"/etc/sudoers || die "visudo failed"
+
+ einfo "Edited /etc/sudoers"
+ fi
+}
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.ebuild
new file mode 100644
index 00000000000..fbc19e2196a
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-2.7.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Scripts necessary for use of vdr as a set-top-box"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="nvram"
+
+RDEPEND="nvram? ( sys-power/nvram-wakeup )
+ app-admin/sudo
+ sys-process/wait_on_pid"
+
+VDR_HOME=/var/vdr
+
+pkg_setup() {
+ enewgroup vdr
+
+ # Add user vdr to these groups:
+ # video - accessing dvb-devices
+ # audio - playing sound when using software-devices
+ # cdrom - playing dvds/audio-cds ...
+ enewuser vdr -1 /bin/bash "${VDR_HOME}" vdr,video,audio,cdrom
+}
+
+src_prepare() {
+ # moved into own package
+ sed -e '/SUBDIRS =/s# bin # #' -i usr/Makefile
+ sed -e '/all:/s#compile##' -i Makefile
+}
+
+src_install() {
+ default
+ dodoc README* TODO ChangeLog
+
+ # create necessary directories
+ diropts -ovdr -gvdr
+ keepdir "${VDR_HOME}"
+
+ local kd
+ for kd in shutdown-data merged-config-files dvd-images; do
+ keepdir "${VDR_HOME}/${kd}"
+ done
+}
+
+pkg_preinst() {
+ local PLUGINS_NEW=0
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.plugins ]]; then
+ PLUGINS_NEW=$(grep -v '^#' "${ROOT}"/etc/conf.d/vdr.plugins |grep -v '^$'|wc -l)
+ fi
+ if [[ ${PLUGINS_NEW} > 0 ]]; then
+ cp "${ROOT}"/etc/conf.d/vdr.plugins "${D}"/etc/conf.d/vdr.plugins
+ else
+ einfo "Migrating PLUGINS setting from /etc/conf.d/vdr to /etc/conf.d/vdr.plugins"
+ local PLUGIN
+ for PLUGIN in $(source "${ROOT}"/etc/conf.d/vdr;echo $PLUGINS); do
+ echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
+ done
+ fi
+
+ has_version "<${CATEGORY}/${PN}-0.5.4"
+ previous_less_than_0_5_4=$?
+
+ has_version "<${CATEGORY}/${PN}-2.6"
+ previous_less_than_2_6=$?
+}
+
+VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_5_4 = 0 ]] ; then
+ elog "\nVDR use now default the --cachedir parameter to store the epg.file"
+ elog "Please do not override this with the EPGFILE variable\n"
+
+ elog "svdrp port 2001 support removed\n"
+
+ elog "--rcu support removed, use media-plugin/vdr-rcu\n"
+ fi
+
+ if [[ $previous_less_than_2_6 = 0 ]]; then
+ elog "${CATEGORY}/${PN} supports now a init script"
+ elog "to start a X server"
+ elog "Please refer for detailed info to"
+ elog "${CATGORY}/${PN} README.x11-setup\n"
+ fi
+
+ if use nvram; then
+ elog "nvram wakeup is optional."
+ elog "To make use of it emerge sys-power/nvram-wakeup.\n"
+ fi
+
+ elog "Plugins which should be used are now set via its"
+ elog "own config-file called /etc/conf.d/vdr.plugins"
+ elog "or enabled via the frontend eselect vdr-plugin.\n"
+
+ if [[ -f "${ROOT}"/etc/conf.d/vdr.dvdswitch ]] &&
+ grep -q ^DVDSWITCH_BURNSPEED= "${ROOT}"/etc/conf.d/vdr.dvdswitch
+ then
+ ewarn "You are setting DVDSWITCH_BURNSPEED in /etc/conf.d/vdr.dvdswitch"
+ ewarn "This no longer has any effect, please use"
+ ewarn "VDR_DVDBURNSPEED in /etc/conf.d/vdr.cd-dvd"
+ fi
+
+ elog "systemd is supported by ${CATEGORY}/${PN}"
+ elog "Please read for detailed info on this"
+ elog "${CATEGORY}/${PN} README.systemd"
+}
+
+pkg_config() {
+ if grep -q /usr/share/vdr/bin/vdrshutdown-really.sh "${ROOT}"/etc/sudoers; then
+
+ einfo "Removing depricated entry from /etc/sudoers:"
+ einfo "- ${VDRSUDOENTRY}"
+
+ cd "${T}"
+ cat >sudoedit-vdr.sh <<-SUDOEDITOR
+ #!/bin/bash
+ sed -i \${1} -e '/\/usr\/share\/vdr\/bin\/vdrshutdown-really.sh *$/d'
+
+ SUDOEDITOR
+ chmod a+x sudoedit-vdr.sh
+
+ VISUAL="${T}"/sudoedit-vdr.sh visudo -f "${ROOT}"/etc/sudoers || die "visudo failed"
+
+ einfo "Edited /etc/sudoers"
+ fi
+}
diff --git a/media-tv/gentoo-vdr-scripts/metadata.xml b/media-tv/gentoo-vdr-scripts/metadata.xml
new file mode 100644
index 00000000000..ecc47f16b87
--- /dev/null
+++ b/media-tv/gentoo-vdr-scripts/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+ <use>
+ <flag name="nvram">Add support for using nvram-wakeup to set wakeup time in bios</flag>
+ </use>
+</pkgmetadata>