summaryrefslogtreecommitdiff
path: root/media-video/bashnapi
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/bashnapi')
-rw-r--r--media-video/bashnapi/Manifest1
-rw-r--r--media-video/bashnapi/bashnapi-1.1.5.ebuild34
-rw-r--r--media-video/bashnapi/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/media-video/bashnapi/Manifest b/media-video/bashnapi/Manifest
new file mode 100644
index 00000000000..5d8e70316fe
--- /dev/null
+++ b/media-video/bashnapi/Manifest
@@ -0,0 +1 @@
+DIST napi_v1.1.5_subotage_0.15.tgz 38080 SHA256 7748a94bcefcbf840f4a7a13fcda2df6442de049f453baa8ff4d4158e21a47d3 SHA512 a8f2b79a3d0767c99af448e7ec9fb8d9b2048876f966ab7ef07c17b7935066387dd20e9535f43947266810d66d28e5e2d02cffc5f033c65112c10744506e86f5 WHIRLPOOL 9dd9c62dfcae68df02d022ce264030290b8d2097fbab7600770e1288c3c44321c65a54ea60e45ad8c30ce0afb8ec4b02fc8cbfdef4a62847fd821ceebf001b02
diff --git a/media-video/bashnapi/bashnapi-1.1.5.ebuild b/media-video/bashnapi/bashnapi-1.1.5.ebuild
new file mode 100644
index 00000000000..11dac0894ad
--- /dev/null
+++ b/media-video/bashnapi/bashnapi-1.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SUB_VER=0.15
+MY_TAR=napi_v${PV}_subotage_${SUB_VER}
+
+DESCRIPTION="Napiprojekt.pl subtitle downloader in bash"
+HOMEPAGE="http://sourceforge.net/projects/bashnapi/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_TAR}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/napi
+
+src_install() {
+ default # for docs
+
+ dobin napi.sh
+}
+
+pkg_postinst() {
+ elog "Optional runtime dependencies:"
+ elog
+ elog " \033[1mmedia-video/subotage\033[0m for subtitle format conversion"
+ elog
+ elog " \033[1mmedia-video/mediainfo\033[0m"
+ elog "or \033[1mmedia-video/mplayer\033[0m for FPS detection (for conversion)"
+}
diff --git a/media-video/bashnapi/metadata.xml b/media-video/bashnapi/metadata.xml
new file mode 100644
index 00000000000..e110571d2fb
--- /dev/null
+++ b/media-video/bashnapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bashnapi</remote-id>
+ </upstream>
+</pkgmetadata>