summaryrefslogtreecommitdiff
path: root/media-video/binkplayer/binkplayer-1.99w.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/binkplayer/binkplayer-1.99w.ebuild')
-rw-r--r--media-video/binkplayer/binkplayer-1.99w.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/binkplayer/binkplayer-1.99w.ebuild b/media-video/binkplayer/binkplayer-1.99w.ebuild
new file mode 100644
index 00000000000..7e0bbfe7d9b
--- /dev/null
+++ b/media-video/binkplayer/binkplayer-1.99w.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+DESCRIPTION="Bink Video! Player"
+HOMEPAGE="http://www.radgametools.com/default.htm"
+# No version on the archives and upstream has said they are not
+# interested in providing versioned archives.
+SRC_URI="mirror://gentoo/${P}.zip"
+
+# distributable per http://www.radgametools.com/binkfaq.htm
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1-r1[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+QA_PREBUILT="opt/bin/BinkPlayer"
+
+src_install() {
+ into /opt
+ dobin BinkPlayer
+}