summaryrefslogtreecommitdiff
path: root/net-analyzer/jffnms
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/jffnms')
-rw-r--r--net-analyzer/jffnms/Manifest1
-rw-r--r--net-analyzer/jffnms/jffnms-0.9.4.ebuild58
-rw-r--r--net-analyzer/jffnms/metadata.xml8
3 files changed, 67 insertions, 0 deletions
diff --git a/net-analyzer/jffnms/Manifest b/net-analyzer/jffnms/Manifest
new file mode 100644
index 00000000000..8c364f7656c
--- /dev/null
+++ b/net-analyzer/jffnms/Manifest
@@ -0,0 +1 @@
+DIST jffnms-0.9.4.tgz 610758 SHA256 8e20d361ad3dc01d800315e3978f1873c3b6d1ebd3bc93a74a3fb8789d56da2b SHA512 4d0c4ed1fbf0107029d92b2ea8f0f02c46d532810dc58bf048c5ffaf79f7f24630101be8319876db1aee3356ced32e7cba2f2494bc8a92a635b0a4e6897c6fe7 WHIRLPOOL 10ac59bd5a52c1803e124b6a47b889bda938760359bd995311486c7156840ddd88092ceba5280fb090dd3484927f6d52121428e4a75d4aca1cb6135ee8cf29e2
diff --git a/net-analyzer/jffnms/jffnms-0.9.4.ebuild b/net-analyzer/jffnms/jffnms-0.9.4.ebuild
new file mode 100644
index 00000000000..ed2b1962b85
--- /dev/null
+++ b/net-analyzer/jffnms/jffnms-0.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit user
+
+DESCRIPTION="Network Management and Monitoring System"
+HOMEPAGE="http://www.jffnms.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres snmp"
+
+RDEPEND="
+ app-mobilephone/smsclient
+ dev-lang/php[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets,wddx]
+ dev-php/PEAR-PEAR
+ media-gfx/graphviz
+ media-libs/gd
+ net-analyzer/fping
+ net-analyzer/net-snmp
+ net-analyzer/nmap
+ net-analyzer/rrdtool[graph]
+ sys-apps/diffutils
+"
+
+pkg_setup() {
+ enewgroup jffnms
+ enewuser jffnms -1 /bin/bash -1 jffnms,apache
+}
+
+src_install(){
+ local INSTALL_DIR="/opt/${PN}"
+ local IMAGE_DIR="${D}${INSTALL_DIR}"
+
+ insinto "${INSTALL_DIR}"
+ doins -r *
+
+ rm -f "${IMAGE_DIR}/LICENSE"
+
+ # Clean up Windows related stuff
+ rm -f "${IMAGE_DIR}"/*.win32.txt
+ rm -rf "${IMAGE_DIR}"/docs/windows
+ rm -rf "${IMAGE_DIR}"/engine/windows
+
+ fowners -R jffnms:apache "${INSTALL_DIR}"
+ fperms -R ug+rw "${INSTALL_DIR}"
+}
+
+pkg_postinst() {
+ elog "${PN} has been partialy installed on your system. However you"
+ elog "still need proceed with final installation and configuration."
+ elog "You can visit https://wiki.gentoo.org/wiki/Jffnms in order"
+ elog "to get detailed information on how to get jffnms up and running."
+}
diff --git a/net-analyzer/jffnms/metadata.xml b/net-analyzer/jffnms/metadata.xml
new file mode 100644
index 00000000000..c174f0301ef
--- /dev/null
+++ b/net-analyzer/jffnms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">jffnms</remote-id>
+ </upstream>
+</pkgmetadata>