summaryrefslogtreecommitdiff
path: root/net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild
new file mode 100644
index 00000000000..62eefee92da
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_1.19 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}