summaryrefslogtreecommitdiff
path: root/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/openpgm/openpgm-5.1.118-r1.ebuild')
-rw-r--r--net-libs/openpgm/openpgm-5.1.118-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/openpgm/openpgm-5.1.118-r1.ebuild b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
new file mode 100644
index 00000000000..f27d8772310
--- /dev/null
+++ b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-any-r1
+
+DESCRIPTION="Open source implementation of the Pragmatic General Multicast specification"
+HOMEPAGE="http://code.google.com/p/openpgm"
+SRC_URI="http://openpgm.googlecode.com/files/libpgm-${PV}~dfsg.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/libpgm-${PV}~dfsg/${PN}/pgm"
+
+src_install() {
+ DOCS=( "${S}"/../doc/. "${S}"/README )
+
+ autotools-utils_src_install
+}