summaryrefslogtreecommitdiff
path: root/net-misc/jlj/jlj-2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/jlj/jlj-2.12.ebuild')
-rw-r--r--net-misc/jlj/jlj-2.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/jlj/jlj-2.12.ebuild b/net-misc/jlj/jlj-2.12.ebuild
new file mode 100644
index 00000000000..47e08819f35
--- /dev/null
+++ b/net-misc/jlj/jlj-2.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A simple console LiveJournal entry system"
+HOMEPAGE="http://umlautllama.com/projects/perl/#jlj"
+SRC_URI="http://umlautllama.com/projects/perl/${PN}_${PV}.tar.gz"
+LICENSE="freedist"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ newbin ${PN}.pl ${PN} || die
+ newdoc .livejournal.rc livejournal.rc
+ dodoc README.JLJ
+}
+
+pkg_postinst() {
+ elog "README.JLJ and a sample livejournal.rc have been installed to"
+ elog "/usr/share/doc/${PF}/"
+}