summaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild')
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild b/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild
new file mode 100644
index 00000000000..365b89db42b
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="evm"
+
+DEPEND="dev-lang/go"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake geth
+ use evm && emake evm
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ use evm && dobin build/bin/evm
+}