summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild
new file mode 100644
index 00000000000..fc375dc22d5
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="=sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )