summaryrefslogtreecommitdiff
path: root/sci-chemistry/xdsi
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/xdsi')
-rw-r--r--sci-chemistry/xdsi/Manifest1
-rw-r--r--sci-chemistry/xdsi/files/0.92-gentoo.patch27
-rw-r--r--sci-chemistry/xdsi/metadata.xml17
-rw-r--r--sci-chemistry/xdsi/xdsi-0.92-r1.ebuild54
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-chemistry/xdsi/Manifest b/sci-chemistry/xdsi/Manifest
new file mode 100644
index 00000000000..e33598d7936
--- /dev/null
+++ b/sci-chemistry/xdsi/Manifest
@@ -0,0 +1 @@
+DIST xdsi_0.92.tar.gz 886028 SHA256 416403f167d26b56965283b407783ea80927ace533df76e330b51ca37c9bb9e4
diff --git a/sci-chemistry/xdsi/files/0.92-gentoo.patch b/sci-chemistry/xdsi/files/0.92-gentoo.patch
new file mode 100644
index 00000000000..f4a37ff1838
--- /dev/null
+++ b/sci-chemistry/xdsi/files/0.92-gentoo.patch
@@ -0,0 +1,27 @@
+ xdsi | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/xdsi b/xdsi
+index cbedee8..1037913 100755
+--- a/xdsi
++++ b/xdsi
+@@ -20,8 +20,8 @@
+ ####################################################################
+ # These are the only two things you should change#
+
+-set Templates "/mydir/templates"
+-set initial "/mydir/SLS-2009"
++set Templates "GENTOOTEMPLATE"
++set initial "./"
+
+
+ ####################################################################
+@@ -121,7 +121,7 @@ your system administrator."
+ }
+
+
+-CheckExecutables "kpdf gnuplot xds_par xdsstat xds-viewer-0.6 convert pointless ipmosflm VIEW"
++CheckExecutables "kpdf gnuplot xds_par xds-viewer convert pointless ipmosflm"
+
+ #wm resizable . 0 0
+
diff --git a/sci-chemistry/xdsi/metadata.xml b/sci-chemistry/xdsi/metadata.xml
new file mode 100644
index 00000000000..431fb2be13b
--- /dev/null
+++ b/sci-chemistry/xdsi/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+XDSi offers you the possibility to process all your datasets in a given directory with minimum effort.
+* You just have to provide it with a resultdirectory and the directory where your frames are stored.
+* All datasets consisting of more than 100 frames within the given directory and all its subdirectories will be processed.
+* For each dataset a space group assignment is done using POINTLESS of the CCP4 software package
+* Plots of the most informative statistics of INTEGRATE.LP, CORRECT.LP and XDSSTAT.LP are generated for each dataset
+* A plot comparing Rmeas, I/sig and Completeness of all the processed datasets is generated
+* You can also generate plots for datasets that have been processed using XDS without XDSi
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/xdsi/xdsi-0.92-r1.ebuild b/sci-chemistry/xdsi/xdsi-0.92-r1.ebuild
new file mode 100644
index 00000000000..6a6c9bb7ec8
--- /dev/null
+++ b/sci-chemistry/xdsi/xdsi-0.92-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A crude interface for running the XDS"
+HOMEPAGE="http://strucbio.biologie.uni-konstanz.de/xdswiki/index.php/Xdsi"
+SRC_URI="ftp://turn5.biologie.uni-konstanz.de/pub/${PN}_${PV}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ app-text/mupdf
+ dev-lang/tk
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ sci-chemistry/xds-bin[smp]
+ sci-visualization/gnuplot
+ sci-visualization/xds-viewer"
+# Need to clarified for licensing
+# sci-chemistry/xdsstat-bin
+DEPEND=""
+
+RESTRICT="mirror bindist"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed \
+ -e "s:GENTOOTEMPLATE:${EPREFIX}/usr/share/${PN}/templates:g" \
+ -e "s:kpdf:mupdf:g" \
+ -e "s:xds-viewer-0.6:xds-viewer:g" \
+ -i ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}/templates
+ doins templates/{*.INP,bohr*,fortran,pauli,info.png,*.pck,tablesf_xdsi}
+ dodoc templates/*.pdf
+}
+
+pkg_postinst() {
+ elog "Documentation can be found here:"
+ elog "ftp://turn14.biologie.uni-konstanz.de/pub/xdsi/xdsi_doc_print.pdf"
+}