summaryrefslogtreecommitdiff
path: root/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild b/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild
new file mode 100644
index 00000000000..491419c74dd
--- /dev/null
+++ b/sys-apps/i2c-tools/i2c-tools-3.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit flag-o-matic toolchain-funcs distutils
+
+DESCRIPTION="I2C tools for bus probing, chip dumping, register-level access helpers, EEPROM decoding, and more"
+HOMEPAGE="http://www.lm-sensors.org/wiki/I2CTools"
+SRC_URI="http://dl.lm-sensors.org/i2c-tools/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~sparc x86"
+IUSE="python"
+
+DEPEND="!<sys-apps/lm_sensors-3"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die
+ if use python ; then
+ cd py-smbus
+ append-cppflags -I../include
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ emake install prefix="${D}"/usr || die
+ rm -rf "${D}"/usr/include # part of linux-headers
+ dodoc CHANGES README
+ local d
+ for d in eeprom eepromer ; do
+ docinto ${d}
+ dodoc ${d}/README*
+ done
+
+ if use python ; then
+ cd py-smbus
+ docinto py-smbus
+ dodoc README*
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}