summaryrefslogtreecommitdiff
path: root/sys-boot/grub/grub-2.02_beta3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-2.02_beta3-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-2.02_beta3-r1.ebuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/sys-boot/grub/grub-2.02_beta3-r1.ebuild b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
index 51efcb7db16..edef1e750f3 100644
--- a/sys-boot/grub/grub-2.02_beta3-r1.ebuild
+++ b/sys-boot/grub/grub-2.02_beta3-r1.ebuild
@@ -219,19 +219,6 @@ grub_configure() {
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
-grub_get_platforms() {
- MULTIBUILD_VARIANTS=()
- local platform
- for platform in "${GRUB_ALL_PLATFORMS[@]}"; do
- if use "grub_platforms_${platform}"; then
- MULTIBUILD_VARIANTS+=( "${platform}" )
- fi
- done
- if (( ${#MULTIBUILD_VARIANTS[@]} == 0 )); then
- MULTIBUILD_VARIANTS=( guessed )
- fi
-}
-
src_configure() {
# Bug 508758.
replace-flags -O3 -O2
@@ -253,7 +240,7 @@ src_configure() {
tc-export BUILD_CC # Bug 485592
# Portage will take care of cleaning up GRUB_PLATFORMS
- grub_get_platforms
+ MULTIBUILD_VARIANTS=( ${GRUB_PLATFORMS:-guessed} )
grub_do grub_configure
}