summaryrefslogtreecommitdiff
path: root/sys-boot
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/refind/Manifest1
-rw-r--r--sys-boot/refind/metadata.xml20
-rw-r--r--sys-boot/refind/refind-0.9.0.ebuild76
-rw-r--r--sys-boot/refind/thiisthing0
4 files changed, 97 insertions, 0 deletions
diff --git a/sys-boot/refind/Manifest b/sys-boot/refind/Manifest
new file mode 100644
index 00000000000..d2c33c70f9d
--- /dev/null
+++ b/sys-boot/refind/Manifest
@@ -0,0 +1 @@
+DIST refind-src-0.9.0.zip 2939724 SHA256 842a01d7964bc8c8000a66e6d08f6fadb4c257d251b1277cebff0bf731e024aa SHA512 c49e3110e6b9f8d44dadae1ab828d3bf59bbce2da9170efed73db961135144ae9963b57d4cc39af2b15ecdf1f289359bda56c3d3e8f72d05be165ae5a3e2654d WHIRLPOOL 225a6b84ea7044e8fe0bab5e268c8c46a4523ab6f408d1bb2a94adfe54afe80c9c83ec0dc104945b332ae6c375c9d041972dee39baa43665588eb0dfc1fe4362
diff --git a/sys-boot/refind/metadata.xml b/sys-boot/refind/metadata.xml
new file mode 100644
index 00000000000..3af998e765d
--- /dev/null
+++ b/sys-boot/refind/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>wraeth@wraeth.id.au</email>
+ <name>Sam Jorna</name>
+ <description>Proxy - Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <longdescription>EFI Boot Manager</longdescription>
+ <use>
+ <flag name="ext2">Builds the EFI binary ext2 filesystem driver</flag>
+ <flag name="ext4">Builds the EFI binary ext4 filesystem driver</flag>
+ <flag name="reiserfs">Builds the EFI binary reiserfs filesystem driver</flag>
+ <flag name="iso9660">Builds the EFI binary iso9660 filesystem driver</flag>
+ <flag name="hfs">Builds the EFI binary hfs filesystem driver</flag>
+ <flag name="btrfs"> Builds the EFI binary btrfs filesystem driver</flag>
+ <flag name="ntfs">Builds the EFI binary ntfs filesystem driver</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-boot/refind/refind-0.9.0.ebuild b/sys-boot/refind/refind-0.9.0.ebuild
new file mode 100644
index 00000000000..2b763a70982
--- /dev/null
+++ b/sys-boot/refind/refind-0.9.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="The rEFInd UEFI Boot Manager by Rod Smith"
+HOMEPAGE="http://www.rodsbooks.com/refind/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
+
+DOCS="BUILDING.txt NEWS.txt README.txt refind.conf-sample {refind,Styles}"
+
+DEPEND=">=sys-boot/gnu-efi-3.0u"
+RDEPEND=""
+
+src_compile() {
+ emake gnuefi || die "Failed to build refind EFI binary"
+
+ cd "${S}/filesystems"
+ for fs in ext2 ext4 reiserfs iso9660 hfs btrfs ; do
+ if use "${fs}" ; then
+ einfo "Building ${fs} filesystem driver"
+ rm -f fsw_efi.o
+
+ # ARCH detection in the Makefile not working
+ use x86 && buildarch=ia32
+ use amd64 && buildarch=x86_64
+ emake DRIVERNAME=${fs} ARCH=${buildarch} -f Make.gnuefi || die "Failed building ${fs} filesystem EFI binary"
+ fi
+ done
+}
+
+src_install() {
+ exeinto "/usr/share/${P}"
+ doexe install.sh
+
+ dodoc -r ${DOCS}
+
+ insinto "/usr/share/${P}/refind"
+ use x86 && doins refind/refind_ia32.efi
+ use amd64 && doins refind/refind_x64.efi
+
+ use x86 && filearch=ia32
+ use amd64 && filearch=x64
+ insinto "/usr/share/${P}/refind/drivers_${filearch}"
+ for fs in ext2 ext4 reiserfs iso9660 hfs btrfs ; do
+ if use "${fs}" ; then doins "drivers_${filearch}/${fs}_${filearch}.efi" ; fi
+ done
+
+ for dir in images icons fonts banners ; do
+ insinto "/usr/share/${P}/refind/${dir}"
+ doins -r "${dir}"
+ done
+
+ insinto "/usr/share/${P}/keys"
+ doins keys/*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "EFI executables have been built and installed into /usr/share/${P}"
+ einfo "You will need to use the provided install script 'install.sh' or"
+ einfo "manually install the binaries into your EFI System Partition."
+ einfo ""
+ einfo "For key generation and binary signing for use with SecureBoot, the"
+ einfo "package app-crypt/sbsigntool can be installed."
+ einfo ""
+ einfo "A sample configration can be found at"
+ einfo "/usr/share/doc/${P}/refind.conf-sample.bz2"
+ einfo ""
+}
diff --git a/sys-boot/refind/thiisthing b/sys-boot/refind/thiisthing
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/sys-boot/refind/thiisthing