summaryrefslogtreecommitdiff
path: root/sys-cluster/teleport
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/files/teleport-makefile-buildflags.patch11
-rw-r--r--sys-cluster/teleport/teleport-2.2.0.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-2.2.1.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-2.2.4.ebuild4
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild2
5 files changed, 21 insertions, 4 deletions
diff --git a/sys-cluster/teleport/files/teleport-makefile-buildflags.patch b/sys-cluster/teleport/files/teleport-makefile-buildflags.patch
new file mode 100644
index 00000000000..d3da35350d8
--- /dev/null
+++ b/sys-cluster/teleport/files/teleport-makefile-buildflags.patch
@@ -0,0 +1,11 @@
+--- work/src/github.com/gravitational/teleport/Makefile
++++ work/src/github.com/gravitational/teleport/Makefile
+@@ -12,7 +12,7 @@
+ PWD ?= `pwd`
+ TELEPORT_DEBUG ?= no
+ GITTAG=v$(VERSION)
+-BUILDFLAGS := $(ADDFLAGS) -ldflags '-w -s'
++BUILDFLAGS ?= $(ADDFLAGS) -ldflags '-w -s'
+
+ RELEASE=teleport-$(GITTAG)-`go env GOOS`-`go env GOARCH`-bin
+ BINARIES=$(BUILDDIR)/tsh $(BUILDDIR)/teleport $(BUILDDIR)/tctl
diff --git a/sys-cluster/teleport/teleport-2.2.0.ebuild b/sys-cluster/teleport/teleport-2.2.0.ebuild
index 73701f3ef24..3fafc3ed333 100644
--- a/sys-cluster/teleport/teleport-2.2.0.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.0.ebuild
@@ -27,8 +27,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-2.2.1.ebuild b/sys-cluster/teleport/teleport-2.2.1.ebuild
index 73701f3ef24..3fafc3ed333 100644
--- a/sys-cluster/teleport/teleport-2.2.1.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.1.ebuild
@@ -27,8 +27,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-2.2.4.ebuild b/sys-cluster/teleport/teleport-2.2.4.ebuild
index d4cdaf815da..90fddb344c0 100644
--- a/sys-cluster/teleport/teleport-2.2.4.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.4.ebuild
@@ -28,8 +28,10 @@ DEPEND="
>=dev-lang/go-1.8.3"
RDEPEND=""
+PATCHES=( "${FILESDIR}"/${PN}-makefile-buildflags.patch )
+
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
index 99620ea6684..3e870fac4bd 100644
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ b/sys-cluster/teleport/teleport-9999.ebuild
@@ -28,7 +28,7 @@ DEPEND="
RDEPEND=""
src_compile() {
- GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*}
pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
popd >/dev/null || die