summaryrefslogtreecommitdiff
path: root/sys-devel/gcc-config/gcc-config-1.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-1.7.3.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.7.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.7.3.ebuild b/sys-devel/gcc-config/gcc-config-1.7.3.ebuild
deleted file mode 100644
index 1f415730f60..00000000000
--- a/sys-devel/gcc-config/gcc-config-1.7.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit unpacker toolchain-funcs multilib
-
-DESCRIPTION="utility to manage compilers"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- PV="${PV}" \
- SUBLIBDIR="$(get_libdir)" \
- install || die
-}
-
-pkg_postinst() {
- # Scrub eselect-compiler remains
- rm -f "${ROOT}"/etc/env.d/05compiler &
-
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- rm -f "${ROOT}"/usr/include/g++{,-v3} &
-
- # Do we have a valid multi ver setup ?
- local x
- for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
- gcc-config ${x}
- done
-
- wait
-}