summaryrefslogtreecommitdiff
path: root/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild')
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
new file mode 100644
index 00000000000..1f9cb413674
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
+inherit autotools-utils eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libmtp
+ >=sys-fs/fuse-2.8
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
+
+AUTOTOOLS_AUTORECONF=1