summaryrefslogtreecommitdiff
path: root/sys-process/fcron/files
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/fcron/files')
-rw-r--r--sys-process/fcron/files/crontab22
-rw-r--r--sys-process/fcron/files/fcron-3.1.1-noreadline.patch14
-rw-r--r--sys-process/fcron/files/fcron.init.358
-rw-r--r--sys-process/fcron/files/fcrontab.25
4 files changed, 99 insertions, 0 deletions
diff --git a/sys-process/fcron/files/crontab b/sys-process/fcron/files/crontab
new file mode 100644
index 00000000000..0ea9562d296
--- /dev/null
+++ b/sys-process/fcron/files/crontab
@@ -0,0 +1,22 @@
+# for fcron
+# $Id$
+
+# fcron:
+# This is NOT the system crontab! fcron does not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron run
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+# Global variables
+SHELL=/bin/bash
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+59 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+9 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
+19 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+29 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
diff --git a/sys-process/fcron/files/fcron-3.1.1-noreadline.patch b/sys-process/fcron/files/fcron-3.1.1-noreadline.patch
new file mode 100644
index 00000000000..161e75b0998
--- /dev/null
+++ b/sys-process/fcron/files/fcron-3.1.1-noreadline.patch
@@ -0,0 +1,14 @@
+Index: fcron-3.1.1/configure.in
+===================================================================
+--- fcron-3.1.1.orig/configure.in
++++ fcron-3.1.1/configure.in
+@@ -86,7 +86,8 @@ AC_FUNC_WAIT3
+ AC_CHECK_LIB(xnet, shutdown)
+ AC_CHECK_LIB(selinux, getcon, [selinuxavail=1], [selinuxavail=0])
+ AC_CHECK_LIB(audit, audit_open, [auditavail=1], [auditavail=0])
+-AX_LIB_READLINE
++AC_ARG_WITH([readline], AS_HELP_STRING([--without-readline], [Build without readline @<:@default=yes@:>@]))
++AS_IF([test "x$with_readline" != "xno"], [AX_LIB_READLINE], [ax_cv_lib_readline=no])
+ AC_CHECK_FUNC(getloadavg, [getloadavg=1], [getloadavg=0])
+ AC_CHECK_LIB(kstat, kstat_open, [kstat=1], [kstat=0])
+ if test $getloadavg -eq 1; then
diff --git a/sys-process/fcron/files/fcron.init.3 b/sys-process/fcron/files/fcron.init.3
new file mode 100644
index 00000000000..209dd49d501
--- /dev/null
+++ b/sys-process/fcron/files/fcron.init.3
@@ -0,0 +1,58 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+FCRON_INSTANCE=${SVCNAME##*.}
+
+configfile() {
+ if [ -n "${FCRON_INSTANCE}" -a "${SVCNAME}" != "fcron" ]; then
+ echo /etc/fcron/fcron.${FCRON_INSTANCE}.conf
+ else
+ echo /etc/fcron/fcron.conf
+ fi
+}
+
+getconfig() {
+ # if there is no configuration file return the default value
+ if ! [ -f $(configfile) ]; then
+ echo $2
+ return 0
+ fi
+
+ sed -n -e 's:^$1[ \t]*=[ \t]*::p' $(configfile)
+}
+
+depend() {
+ config $(configfile)
+
+ use logger
+ need clock hostname
+ # provide the cron service if we are the main instance
+ [ "${SVCNAME}" = "fcron" ] && provide cron
+}
+
+command="/usr/libexec/fcron"
+command_args="-c $(configfile)"
+pidfile=$(getconfig pidfile /var/run/fcron.pid)
+fcrontabs=$(getconfig fcrontabs /var/spool/fcron)
+
+extra_started_commands="reload"
+
+start_pre() {
+ if [ ! -e $(configfile) ]; then
+ eerror "You will need to create $(configfile) first"
+ eerror "There is a sample in /etc/fcron"
+ return 1
+ fi
+
+ if [ ! -d ${fcrontabs} ]; then
+ ebegin "Creating missing spooldir ${fcrontabs}"
+ ${command} --newspooldir ${fcrontabs}
+ eend $?
+ fi
+}
+
+reload() {
+ kill -HUP `cat ${pidfile}`
+}
diff --git a/sys-process/fcron/files/fcrontab.2 b/sys-process/fcron/files/fcrontab.2
new file mode 100644
index 00000000000..e12c1178752
--- /dev/null
+++ b/sys-process/fcron/files/fcrontab.2
@@ -0,0 +1,5 @@
+# $Id$
+# Script for checking system crontabs and creating the fcron systab.
+# Runs every 10 minutes, does not mail output, doesn't log job runs
+# except for errors.
+@mail(false),nolog(true) 10 /usr/libexec/check_system_crontabs -s 0