summaryrefslogtreecommitdiff
path: root/sys-process/incron
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/incron')
-rw-r--r--sys-process/incron/Manifest1
-rw-r--r--sys-process/incron/files/incron-0.5.10+gcc-4.7.patch12
-rw-r--r--sys-process/incron/files/incrond.init21
-rw-r--r--sys-process/incron/files/incrond.service9
-rw-r--r--sys-process/incron/incron-0.5.10-r1.ebuild40
-rw-r--r--sys-process/incron/incron-0.5.10.ebuild39
-rw-r--r--sys-process/incron/metadata.xml8
7 files changed, 130 insertions, 0 deletions
diff --git a/sys-process/incron/Manifest b/sys-process/incron/Manifest
new file mode 100644
index 00000000000..25e8efb368e
--- /dev/null
+++ b/sys-process/incron/Manifest
@@ -0,0 +1 @@
+DIST incron-0.5.10.tar.gz 203158 SHA256 5d4abadb5f16c26e4f728a6433ad22f7655663b5812fbd4f94e852050f38e78a SHA512 653817c35059b5305e059137eac78f21a7d32ccc03fc92ba282eab66ba5f3d2c83a1a571ebdcead8df3ed500a7fd30cfa46375c635450b08d2bd8d00dfe86df3 WHIRLPOOL 563730d7d2ac9122d6650431c259b50f6e0fd5cbbaa2e64383c756722efd9bf6a8595cfee8bceff006afffff8ce49702b6d44de1c4156498fb559f4ef00e3458
diff --git a/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch b/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch
new file mode 100644
index 00000000000..a1b690510f3
--- /dev/null
+++ b/sys-process/incron/files/incron-0.5.10+gcc-4.7.patch
@@ -0,0 +1,12 @@
+Index: incron-0.5.10/icd-main.cpp
+===================================================================
+--- incron-0.5.10.orig/icd-main.cpp
++++ incron-0.5.10/icd-main.cpp
+@@ -24,6 +24,7 @@
+ #include <dirent.h>
+ #include <syslog.h>
+ #include <errno.h>
++#include <unistd.h>
+ #include <sys/poll.h>
+ #include <sys/stat.h>
+ #include <cstdio>
diff --git a/sys-process/incron/files/incrond.init b/sys-process/incron/files/incrond.init
new file mode 100644
index 00000000000..1137b81bd5a
--- /dev/null
+++ b/sys-process/incron/files/incrond.init
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use clock logger
+ need localmount
+}
+
+start() {
+ ebegin "Starting incrond"
+ start-stop-daemon --start --pidfile /var/run/incrond.pid --exec /usr/sbin/incrond -- -f /etc/incron.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping incrond"
+ start-stop-daemon --stop --pidfile /var/run/incrond.pid
+ eend $?
+}
diff --git a/sys-process/incron/files/incrond.service b/sys-process/incron/files/incrond.service
new file mode 100644
index 00000000000..a3d2a9b0b3b
--- /dev/null
+++ b/sys-process/incron/files/incrond.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Inotify System Scheduler
+
+[Service]
+ExecStart=/usr/sbin/incrond --foreground -f /etc/incron.conf
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/sys-process/incron/incron-0.5.10-r1.ebuild b/sys-process/incron/incron-0.5.10-r1.ebuild
new file mode 100644
index 00000000000..50a052a28db
--- /dev/null
+++ b/sys-process/incron/incron-0.5.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils linux-info systemd toolchain-funcs
+
+DESCRIPTION="inotify based cron daemon"
+HOMEPAGE="http://incron.aiken.cz/"
+SRC_URI="http://inotify.aiken.cz/download/incron/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# < 2.6.18 => INOTIFY, >= 2.6.18 => INOTIFY_USER
+# It should be ok to expect at least 2.6.18
+CONFIG_CHECK="~INOTIFY_USER"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCDIR=/usr/share/doc/${PF} install
+
+ newinitd "${FILESDIR}/incrond.init" incrond
+ systemd_dounit "${FILESDIR}/incrond.service"
+
+ dodoc CHANGELOG README TODO
+}
diff --git a/sys-process/incron/incron-0.5.10.ebuild b/sys-process/incron/incron-0.5.10.ebuild
new file mode 100644
index 00000000000..dc31eb2113d
--- /dev/null
+++ b/sys-process/incron/incron-0.5.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils linux-info toolchain-funcs
+
+DESCRIPTION="inotify based cron daemon"
+HOMEPAGE="http://incron.aiken.cz/"
+SRC_URI="http://inotify.aiken.cz/download/incron/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# < 2.6.18 => INOTIFY, >= 2.6.18 => INOTIFY_USER
+# It should be ok to expect at least 2.6.18
+CONFIG_CHECK="~INOTIFY_USER"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr DOCDIR=/usr/share/doc/${PF} install
+
+ newinitd "${FILESDIR}/incrond.init" incrond
+
+ dodoc CHANGELOG README TODO
+}
diff --git a/sys-process/incron/metadata.xml b/sys-process/incron/metadata.xml
new file mode 100644
index 00000000000..b71a8a2e034
--- /dev/null
+++ b/sys-process/incron/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+</pkgmetadata>