summaryrefslogtreecommitdiff
path: root/www-client/chromium/chromium-47.0.2503.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-47.0.2503.0.ebuild')
-rw-r--r--www-client/chromium/chromium-47.0.2503.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/www-client/chromium/chromium-47.0.2503.0.ebuild b/www-client/chromium/chromium-47.0.2503.0.ebuild
index a29ad8655d7..346ae3ab127 100644
--- a/www-client/chromium/chromium-47.0.2503.0.ebuild
+++ b/www-client/chromium/chromium-47.0.2503.0.ebuild
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD hotwording? ( no-source-code )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome gnome-keyring hidpi hotwording kerberos neon pic +proprietary-codecs pulseaudio selinux +tcmalloc"
+IUSE="cups gnome gnome-keyring hidpi hotwording kerberos neon pic +proprietary-codecs pulseaudio selinux +tcmalloc widevine"
RESTRICT="proprietary-codecs? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -100,7 +100,8 @@ RDEPEND+="
virtual/opengl
virtual/ttf-fonts
selinux? ( sec-policy/selinux-chromium )
- tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )"
+ tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )
+ widevine? ( www-plugins/chrome-binary-plugins[widevine(-)] )"
# Python dependencies. The DEPEND part needs to be kept in sync
# with python_check_deps.
@@ -190,6 +191,7 @@ src_prepare() {
# fi
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
+ epatch "${FILESDIR}/chromium-widevine-r1.patch"
epatch_user
@@ -370,7 +372,8 @@ src_configure() {
$(gyp_use hotwording enable_hotwording)
$(gyp_use kerberos)
$(gyp_use pulseaudio)
- $(gyp_use tcmalloc use_allocator tcmalloc none)"
+ $(gyp_use tcmalloc use_allocator tcmalloc none)
+ $(gyp_use widevine enable_widevine)"
# Use explicit library dependencies instead of dlopen.
# This makes breakages easier to detect by revdep-rebuild.
@@ -546,6 +549,7 @@ src_install() {
fperms 4755 "${CHROMIUM_HOME}/chrome-sandbox"
doexe out/Release/chromedriver || die
+ use widevine && doexe out/Release/libwidevinecdmadapter.so
# if ! use arm; then
# doexe out/Release/nacl_helper{,_bootstrap} || die