summaryrefslogtreecommitdiff
path: root/www-client/vimb/vimb-2.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/vimb/vimb-2.11.ebuild')
-rw-r--r--www-client/vimb/vimb-2.11.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/www-client/vimb/vimb-2.11.ebuild b/www-client/vimb/vimb-2.11.ebuild
deleted file mode 100644
index 9e5ce11640f..00000000000
--- a/www-client/vimb/vimb-2.11.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="a fast, lightweight, vim-like browser based on webkit"
-HOMEPAGE="http://fanglingsu.github.io/vimb/"
-SRC_URI="https://github.com/fanglingsu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk3"
-
-RDEPEND="
- >=net-libs/libsoup-2.38:2.4
- !gtk3? (
- >=net-libs/webkit-gtk-1.5.0:2
- x11-libs/gtk+:2
- )
- gtk3? (
- >=net-libs/webkit-gtk-1.5.0:3
- x11-libs/gtk+:3
- )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- # force verbose build
- sed -e '/@echo "\($(CC)\|${CC}\) $@"/d' \
- -e 's/@$(CC)/$(CC)/' \
- -i src/Makefile || die
-
- epatch_user
-}
-
-src_compile() {
- local myconf
- use gtk3 && myconf+=" GTK=3"
-
- emake CC="$(tc-getCC)" ${myconf}
-}
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" install
-}