summaryrefslogtreecommitdiff
path: root/www-misc/bookmarksync
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/bookmarksync')
-rw-r--r--www-misc/bookmarksync/Manifest1
-rw-r--r--www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild43
-rw-r--r--www-misc/bookmarksync/metadata.xml15
3 files changed, 59 insertions, 0 deletions
diff --git a/www-misc/bookmarksync/Manifest b/www-misc/bookmarksync/Manifest
new file mode 100644
index 00000000000..8436dc3efdf
--- /dev/null
+++ b/www-misc/bookmarksync/Manifest
@@ -0,0 +1 @@
+DIST bookmarksync-0.3.4.tar.gz 14324 SHA256 3111f55a8b1f6dd4d2f343bef4d15b58186a429505760ac8f38e2c4e4592fba8 SHA512 97464e32e9c21010eccf34b9bc94ce67d20f9b7a1f00b4e10e7096c0bde527a8b2a83a05c8623aa009fa0ab1895b025241aba2dfaf6881755bf05682b9e710d0 WHIRLPOOL 9a93d1f06c1dcab0da5c7df437b2d6a18e69d70fba0668ea3a7c59a2f96e30fe6189ea72ca57a8eab40baa31b579866abb81fc3c50d7ce15a3b474c43369c364
diff --git a/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
new file mode 100644
index 00000000000..d2995aaff0e
--- /dev/null
+++ b/www-misc/bookmarksync/bookmarksync-0.3.4-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bookmarksync synchronizes various browser bookmark files"
+HOMEPAGE="http://sourceforge.net/projects/booksync/"
+SRC_URI="mirror://sourceforge/booksync/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+
+IUSE="perl"
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|g++|$(CXX) $(CFLAGS)|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ tc-export CXX
+}
+
+src_install () {
+ dobin bookmarksync
+ if use perl ; then
+ dobin tools/bookmarksync.pl
+ dodoc tools/README.tools
+ fi
+ dodoc README TODO DEVELOPERS
+}
+
+pkg_postinst () {
+ use perl && ewarn "You will need to modify bookmarksync.pl before use"
+}
diff --git a/www-misc/bookmarksync/metadata.xml b/www-misc/bookmarksync/metadata.xml
new file mode 100644
index 00000000000..3076f2d83aa
--- /dev/null
+++ b/www-misc/bookmarksync/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ bookmarksync is a tool used for synchronizing different bookmark files
+ and types. It preserves current bookmark structures and sorts in new
+ ones correctly in existing directorys or create new one if necessary.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">booksync</remote-id>
+ </upstream>
+</pkgmetadata>