summaryrefslogtreecommitdiff
path: root/www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild')
-rw-r--r--www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild b/www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild
new file mode 100644
index 00000000000..ef882781ff4
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20140708-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_prepare() {
+ mv Makefile{.boot,} || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ newconfd "${FILESDIR}"/${PN}.conffile bozohttpd
+ newinitd "${FILESDIR}"/${PN}.initscript bozohttpd
+}