summaryrefslogtreecommitdiff
path: root/www-servers/fnord/fnord-1.10-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/fnord/fnord-1.10-r2.ebuild')
-rw-r--r--www-servers/fnord/fnord-1.10-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-servers/fnord/fnord-1.10-r2.ebuild b/www-servers/fnord/fnord-1.10-r2.ebuild
new file mode 100644
index 00000000000..48f64b429f0
--- /dev/null
+++ b/www-servers/fnord/fnord-1.10-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils flag-o-matic toolchain-funcs user
+
+DESCRIPTION="Yet another small httpd"
+HOMEPAGE="http://www.fefe.de/fnord/"
+SRC_URI="http://www.fefe.de/fnord/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="hppa ppc sparc x86"
+IUSE="auth"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/daemontools
+ sys-apps/ucspi-tcp"
+
+pkg_setup() {
+ enewgroup nofiles 200
+ enewuser fnord -1 -1 /etc/fnord nofiles
+ enewuser fnordlog -1 -1 /etc/fnord nofiles
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}"-1.10-gentoo.diff
+}
+
+src_compile() {
+ # Fix for bug #45716
+ replace-sparc64-flags
+
+ use auth && \
+ append-flags -DAUTH
+
+ emake DIET="" CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ dobin fnord-conf fnord || die
+ dodoc TODO README* SPEED CHANGES
+}