summaryrefslogtreecommitdiff
path: root/www-servers/h2o/h2o-2.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/h2o/h2o-2.2.3.ebuild')
-rw-r--r--www-servers/h2o/h2o-2.2.3.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/www-servers/h2o/h2o-2.2.3.ebuild b/www-servers/h2o/h2o-2.2.3.ebuild
deleted file mode 100644
index 1ad16970758..00000000000
--- a/www-servers/h2o/h2o-2.2.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-inherit cmake-utils ruby-single systemd user
-
-DESCRIPTION="An optimized HTTP server with support for HTTP/1.x and HTTP/2"
-HOMEPAGE="https://h2o.examp1e.net"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl +mruby"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )"
-DEPEND="${RDEPEND}
- mruby? (
- sys-devel/bison
- ${RUBY_DEPS}
- )"
-
-pkg_setup() {
- enewgroup h2o
- enewuser h2o -1 -1 -1 h2o
-}
-
-src_prepare() {
- # Leave optimization level to user CFLAGS
- sed -i 's/-O2 -g ${CC_WARNING_FLAGS} //g' ./CMakeLists.txt \
- || die "sed fix failed!"
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/h2o
- -DWITH_MRUBY="$(usex mruby)"
- -DWITHOUT_LIBS=ON
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- newinitd "${FILESDIR}"/h2o.initd h2o
- systemd_dounit "${FILESDIR}"/h2o.service
-
- insinto /etc/h2o
- doins "${FILESDIR}"/h2o.conf
-
- keepdir /var/log/h2o
- fperms 0700 /var/log/h2o
-
- keepdir /var/www/localhost/htdocs
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/h2o.logrotate h2o
-}