summaryrefslogtreecommitdiff
path: root/www-servers/resin/files
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/resin/files')
-rw-r--r--www-servers/resin/files/4.0.44/VarType.java.patch35
-rw-r--r--www-servers/resin/files/4.0.44/build.xml.patch59
-rw-r--r--www-servers/resin/files/4.0.44/resin-compile.patch53
-rw-r--r--www-servers/resin/files/4.0.44/resin.conf16
-rw-r--r--www-servers/resin/files/4.0.44/resin.init37
5 files changed, 0 insertions, 200 deletions
diff --git a/www-servers/resin/files/4.0.44/VarType.java.patch b/www-servers/resin/files/4.0.44/VarType.java.patch
deleted file mode 100644
index 05f03f214cb..00000000000
--- a/www-servers/resin/files/4.0.44/VarType.java.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- modules/kernel/src/com/caucho/config/reflect/VarType.java.orig 2015-08-12 21:05:11.892000000 +0000
-+++ modules/kernel/src/com/caucho/config/reflect/VarType.java 2015-08-12 21:06:04.475000000 +0000
-@@ -33,6 +33,7 @@
- import java.lang.reflect.GenericDeclaration;
- import java.lang.reflect.Type;
- import java.lang.reflect.TypeVariable;
-+import java.lang.reflect.AnnotatedType;
- import java.util.Set;
-
- import com.caucho.inject.Module;
-@@ -188,7 +189,23 @@
-
- return sb.toString();
- }
--
-+
-+ public AnnotatedType[] getAnnotatedBounds() {
-+ return null;
-+ }
-+
-+ public Annotation[] getDeclaredAnnotations() {
-+ return null;
-+ }
-+
-+ public Annotation[] getAnnotations() {
-+ return null;
-+ }
-+
-+ public <T extends Annotation> T getAnnotation(Class<T> klass) {
-+ return null;
-+ }
-+
- static class GenericDeclarationImpl implements GenericDeclaration {
- @Override
- public TypeVariable<?>[] getTypeParameters()
diff --git a/www-servers/resin/files/4.0.44/build.xml.patch b/www-servers/resin/files/4.0.44/build.xml.patch
deleted file mode 100644
index dc3a413fc0b..00000000000
--- a/www-servers/resin/files/4.0.44/build.xml.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- build.xml.orig 2015-08-12 23:14:20.302000000 +0000
-+++ build.xml 2015-08-12 23:14:47.909000000 +0000
-@@ -12,7 +12,7 @@
- <property name="eclipse.home" value="${user.home}/eclipse"/>
-
- <target name="compile"
-- depends="init, hessian, javaee, jaxstream, portlet, script, resin-kernel, quercus-dev, resin, ecmascript, cdi, webutil, conf, ext, j2ee-management, resin-eclipselink, gae, jasper">
-+ depends="init, hessian, javaee, jaxstream, portlet, script, resin-kernel, quercus-dev, resin, ecmascript, cdi, webutil, conf, ext, j2ee-management, gae">
- </target>
-
- <!--
-@@ -27,10 +27,6 @@
- </antcall>
- </target>
- -->
-- <target name="resin-eclipselink" depends="eclipselink">
-- <copy file="modules/eclipselink/dist/resin-eclipselink.jar"
-- todir="${resin.lib}"/>
-- </target>
-
- <target name="richfaces" depends="init">
- <antcall target="artifact" inheritRefs="true">
-@@ -92,13 +88,6 @@
- </antcall>
- </target>
-
-- <target name="eclipselink" depends="init">
-- <antcall target="module" inheritRefs="true">
-- <param name="module.name" value="eclipselink"/>
-- <param name="module.jar" value="resin-eclipselink.jar"/>
-- </antcall>
-- </target>
--
- <!-- gae APIs for quercus testing -->
- <target name="gae" depends="init">
- <antcall target="module" inheritRefs="true">
-@@ -437,13 +426,6 @@
- </antcall>
- </target>
-
-- <target name="jasper" depends="init">
-- <antcall target="module" inheritRefs="true">
-- <param name="module.name" value="jasper"/>
-- <param name="module.jar" value="resin-jasper.jar"/>
-- </antcall>
-- </target>
--
- <target name="version">
- <copy file="${resin.modules}/kernel/src/com/caucho/Version.tmpl"
- tofile="${resin.modules}/kernel/src/com/caucho/Version.java"
-@@ -903,7 +885,7 @@
- <delete dir="${dist}/${dist.name}"/>
- </target>
-
-- <target name="dist" depends="dist.clean, configure, compile, update, junit, eclipselink, artifacts, resin.dist.build, dist.package, quercus.war"/>
-+ <target name="dist" depends="dist.clean, configure, compile, update, junit, artifacts, resin.dist.build, dist.package, quercus.war"/>
-
- <target name="configure" depends="init">
- <copy tofile="modules/c/src/resin/Makefile.in"
diff --git a/www-servers/resin/files/4.0.44/resin-compile.patch b/www-servers/resin/files/4.0.44/resin-compile.patch
deleted file mode 100644
index fa6dd390f3f..00000000000
--- a/www-servers/resin/files/4.0.44/resin-compile.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- modules/quercus/src/com/caucho/quercus/lib/xml/XMLWriter.java.orig 2015-08-12 22:15:36.022000000 +0000
-+++ modules/quercus/src/com/caucho/quercus/lib/xml/XMLWriter.java 2015-08-12 22:16:45.761000000 +0000
-@@ -29,6 +29,7 @@
-
- package com.caucho.quercus.lib.xml;
-
-+import com.caucho.quercus.annotation.Optional;
- import com.caucho.quercus.annotation.*;
- import com.caucho.quercus.env.*;
- import com.caucho.util.L10N;
---- modules/quercus/src/com/caucho/quercus/lib/xml/XMLWriterModule.java.orig 2015-08-12 22:24:52.586000000 +0000
-+++ modules/quercus/src/com/caucho/quercus/lib/xml/XMLWriterModule.java 2015-08-12 22:25:10.385000000 +0000
-@@ -29,6 +29,7 @@
-
- package com.caucho.quercus.lib.xml;
-
-+import com.caucho.quercus.annotation.Optional;
- import com.caucho.quercus.annotation.*;
- import com.caucho.quercus.env.*;
- import com.caucho.util.L10N;
---- modules/resin/src/com/caucho/security/x509/X509Parser.java.orig 2015-08-12 22:38:56.323000000 +0000
-+++ modules/resin/src/com/caucho/security/x509/X509Parser.java 2015-08-12 22:39:17.249000000 +0000
-@@ -29,6 +29,7 @@
-
- package com.caucho.security.x509;
-
-+import com.caucho.util.Base64;
- import com.caucho.util.*;
- import com.caucho.vfs.*;
- import java.io.*;
---- modules/resin/src/com/caucho/server/admin/ManagementAuthenticator.java.orig 2015-08-12 22:39:56.138000000 +0000
-+++ modules/resin/src/com/caucho/server/admin/ManagementAuthenticator.java 2015-08-12 22:40:29.323000000 +0000
-@@ -33,6 +33,7 @@
- import com.caucho.security.AbstractAuthenticator;
- import com.caucho.security.PasswordUser;
- import com.caucho.util.*;
-+import com.caucho.util.Base64;
-
- import java.security.Principal;
- import java.util.*;
---- modules/resin/src/com/caucho/ejb/session/AbstractSessionManager.java.orig 2015-08-12 22:42:36.743000000 +0000
-+++ modules/resin/src/com/caucho/ejb/session/AbstractSessionManager.java 2015-08-12 22:42:53.030000000 +0000
-@@ -379,9 +379,7 @@
- @Override
- public <T> T getLocalProxy(Class<T> api)
- {
-- OwnerCreationalContext owner = new OwnerCreationalContext(null);
--
-- return getSessionContext(api).createProxy(owner);
-+ return null;
- }
-
- protected <T> AbstractSessionContext<X,T>
diff --git a/www-servers/resin/files/4.0.44/resin.conf b/www-servers/resin/files/4.0.44/resin.conf
deleted file mode 100644
index a48840b5e9f..00000000000
--- a/www-servers/resin/files/4.0.44/resin.conf
+++ /dev/null
@@ -1,16 +0,0 @@
-# JVM Runtime
-# Using the default setting, it will determine your JVM from the system-vm
-# set using java-config.
-# See java-config(1) manual page for assistance in determining this value.
-
-# You can override this value with whatever JDK you want.
-# For a list of valid values for GENTOO_VM see output of
-# java-config -L
-#GENTOO_VM=sun-jdk-1.5
-
-# Verbose starting and stopping? (yes/no, defaults to no)
-#VERBOSE="yes"
-
-# Select which server will be started, this is an advanced feature, please refer
-# to Resin documentation.
-SERVER_ID=""
diff --git a/www-servers/resin/files/4.0.44/resin.init b/www-servers/resin/files/4.0.44/resin.init
deleted file mode 100644
index 6103369d40e..00000000000
--- a/www-servers/resin/files/4.0.44/resin.init
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-depend() {
- need net
- use dns logger mysql postgresql
-}
-
-runResin() {
- JAVA_HOME=$(java-config -O)
- [ -n "${GENTOO_VM}" ] && JAVA_HOME=$(java-config --select-vm="${GENTOO_VM}" -O)
- export JAVA_HOME
-
- local extraArgs=
- if [ "${VERBOSE}" = "yes" ]; then
- extraArgs="-verbose"
- fi
-
- local msg="${1}"
- shift
-
- local cmdline="${JAVA_HOME}/bin/java -jar /usr/share/resin/lib/resin.jar -conf /etc/resin/resin.xml -server \"${SERVER_ID}\" -resin-home __RESIN_HOME__ -root-directory __RESIN_HOME__ ${extraArgs} ${@}"
-
- ebegin "${msg}"
- su - resin -c "${cmdline}"
- eend $?
-}
-
-start() {
- runResin "Starting Resin" "start"
-}
-
-stop() {
- runResin "Stopping Resin" "shutdown"
-}